OpenVPN DNS interne



  • Bonjour,
    Jeune utilisateur de pfsense, je me permets de me tourner vers vous, car je rencontre un problème.

    Schema :
    0_1527283415428_Dessin1.png
    Le voici :
    J'ai configurer un serveur OpenVPN qui a l'heure actuelle me permet de bien accéder a mon réseaux local. Mais j'aimerai au lieu d'utiliser un DNS externe type 8.8.8.8. Utiliser mon DNS interne 192.168.1.1 pour pouvoir résoudre mes nom interne.

    J'ai pourtant bien renseigner dans les paramètre de mon serveur.

    Ci-dessous les paramètre de mon serveur.
    0_1527283126637_screencapture-pfsense-fochcraft-local-vpn_openvpn_server-php-2018-05-25-23_12_36-min.png

    Je vous remercie d'avance.



  • Les débutants doivent lire A LIRE EN PREMIER ...

    Votre schéma montre 2 firewall successifs : quel est l'intérêt ?
    (pfSense a bien plus de fonctions de firewall qu'une appliance SonicWall, à priori ...)

    Dans votre config de serveur OpenVPN, vous avez indiqué, et c'est correct,

    • DNS Server Enable : coché
    • au moins un serveur DNS indiqué
      Si vous avez un client correctement connecté, le réglage doit être visible, avec 'ipconfig /all' (client Windows).
      L'avez vous vérifié ? (ce qu'il aurait fallu faire avant de poster)

    NB : éviter les adressages réseaux trop simples comme 192.168.0.x/24 et 192.168.1.x/24 !



  • This post is deleted!


  • Merci du retour.

    J'ai résolu la moitié du problème.

    Le problème été que la plage IP du VPN n’était pas renseignée dans mon DNS.

    Je peux maintenant résoudre les noms internes.

    Mais malheureusement pas les noms externes.



  • @focheur91300 said in OpenVPN DNS interne:

    Mais malheureusement pas les noms externes.

    Problème classique maintes fois traité sur ce forum (je ne sait ce qu'il reste de l'historique depuis cette migration avec cette interface ALC). Vous avez raison sur votre choix de principe pour dns. 192.168.1.1 doit utiliser un forwarder pour les noms qu'il ne connait pas. Il fourni une résolution pour les noms locaux.



  • I wish it were that easy! haha, I used my public IP there. One thing I did notice was in my server.conf I had server 10.8.0.0... so I changed it to phungyou 10.8.0.0 and that seemed to fix it! Worked great for a bit, and then I tried to connect via my hotspot on my phone and it says "TLS failed" and after doing route flush I cannot connect anymore at all and get TLS failures. whoops.
    Plex Lucky Patcher Kodi