Squid3 - transparent proxy not working

  • When I enable the transparent proxy after installing squid3, it does not get applied - HTTP traffic is not being redirected through squid. Manually pointing the browser to use [pfsense-ip]:3128 as proxy still works.
    This problem does not occur on squid2.

  • Yes - I have seen this too.  The package is only BETA and I'm not even sure the level of active development on it right now.  If you or anyone else wants to dive in and fix it, I know of several users that would be pretty happy.

  • I just wanted to point it out so that nobody else wonders why his transparent proxy doesn't work.
    I already downgraded my newly-setup pfSense machine to squid2, but the next time I get a chance to install squid3, I will check what this problem is caused by - I'm suspecting the forwarding rule isn't being added correctly.

  • Currently using 1.2.3-RC2 built on Sun Aug 30 11:37:03 UTC 2009 FreeBSD
    Wondering if the transparent proxy in squid3 "3.0.8_08" is working?  I also have lightsquid "1.7.1" installed.  I have check the cache.log and access.log.  Squid3 works as the previous poster indicated when set manually.  I uninstalled squid2.6 due to getting numerous pinger(s).  I understand the package is still in BETA, but was wondering if any further development has been done since the last post.  Thanks again for the great product!!!

    One more question - Tuning of squid (like in squid2.6 - http://forum.pfsense.org/index.php/topic,7186.msg59302.html#msg59302).  Does that need to be applied in Squid3?

  • Good afternoon :) Squid3 still experimental. Stick to squid (on package).

    Davao City PH

  • That is what I did, I cleared out the squid logs, added the fine tuning statements, reinstalled squid 2.6 package and lightsquid.  I verified the processes, cpu load, adjusted the squid settings, rebooted the firewall and now I am monitoring (top & tail -f /var/squid/log/access.log)  looks like all is well.  I am constanting learning, reading up on the squid's website about the different log statements and so forth.  So far all looks good.  I realized that after I make any changes to squid using pfsense gui, I get another pinger process.  I now know to "kill" those additional processes using "kill process#" within top.  Thanks again to everyone.

Log in to reply