pfsense upgraded just ruined my day



  • I just took the upgrade in the gui from one minor 2.4.x version to the next and now my APU firewall won't boot.

    Booting from HD just stops dead. All I get is:
    //bboooott//ccoonnffiigg:: --SS111155220000 --DD

    Booting from usb All I see is:

    //bboooott//ccoonnffiigg:: --SS111155220000 --DD
    ggppttbboooott:: eerrrroorr 11 llbbaa 11112266775522

    IInnvvaalliidd ffoorrmmaatt

    ggppttbboooott:: eerrrroorr 11 llbbaa 11112266776600

    ggppttbboooott:: NNoo //bboooott//kkeerrnneell//kkeerrnneell oonn 00::aadd((00pp33))

    Totally dead in the water. Last mother%&$% thing I needed today.



  • Do you guys not even support your own hardware anymore? There are only 2 usb images available for download and neither seem to boot on my netgate branded 2014 APU. WTF???? This project has gone to hell since its gotten all corporate.


  • Galactic Empire Netgate Administrator

    Hi,

    What image did you download? It needs to be pfSense-CE-memstick-serial-2.4.3-RELEASE-amd64.img.gz

    Download the correct image from: https://www.pfsense.org/download/

    Follow these steps https://www.netgate.com/docs/pfsense/solutions/apu/reinstall-pfsense.html

    Do you guys not even support your own hardware anymore? There are only 2 usb images available for download and neither seem to boot on my netgate branded 2014 APU. WTF??? This project has gone to hell since its gotten all corporate.

    Please tone it down a notch. There's no reason for that kind of attitude. To this day people run pfSense on APU's just fine.



  • @ivor said in pfsense upgraded just ruined my day:

    https://www.netgate.com/docs/pfsense/solutions/apu/reinstall-pfsense.html

    I'm using pfSense-CE-memstick-serial-2.4.3-RELEASE-amd64.img.gz

    Build date: Apr 5 2014
    System memory size: 4592 MB

    Press F12 for boot menu.

    Searching bootorder for: HALT
    drive 0x000f24d0: PCHS=0/0/0 translation=lba LCHS=499/16/63 s=503808
    drive 0x000f2500: PCHS=16383/16/63 translation=lba LCHS=1024/255/63 s=58626288
    Space available for UMB: c1000-ee800, f0000-f24d0
    Returned 253952 bytes of ZoneHigh
    e820 map has 7 items:
    0: 0000000000000000 - 000000000009fc00 = 1 RAM
    1: 000000000009fc00 - 00000000000a0000 = 2 RESERVED
    2: 00000000000f0000 - 0000000000100000 = 2 RESERVED
    3: 0000000000100000 - 00000000df14e000 = 1 RAM
    4: 00000000df14e000 - 00000000e0000000 = 2 RESERVED
    5: 00000000f8000000 - 00000000f9000000 = 2 RESERVED
    6: 0000000100000000 - 000000011f000000 = 1 RAM
    enter handle_19:
    NULL
    Booting from Hard Disk...
    Booting from 0000:7c00
    gptboot: error 1 lba 1271385
    gptboot: unable to read backup GPT header
    gptboot: error 1 lba 1269328
    //bboooott//ccoonnffiigg:: --SS111155220000 --DD

    ggppttbboooott:: eerrrroorr 11 llbbaa 11112266775522

    IInnvvaalliidd ffoorrmmaatt

    ggppttbboooott:: eerrrroorr 11 llbbaa 11112266776600

    ggppttbboooott:: NNoo //bboooott//kkeerrnneell//kkeerrnneell oonn 00::aadd((00pp33))

    FFrreeeeBBSSDD//xx8866 bboooott

    DDeeffaauulltt:: 00::aadd((00pp33))//bboooott//kkeerrnneell//kkeerrnneell

    bboooott::

    I have no idea where all the double chars are coming from. AFAIK I have echo turned off in minicom. Maybe its something with this new #*%$ usb-c serial cable.

    If i press F12 and then 1 to boot from usb:

    Press F12 for boot menu.

    Select boot device:

    1. USB MSC Drive Real-Way Flash Disk 1.1
    2. AHCI/0: INTEL SSDMCEAC030B3 ATA-9 Hard-Disk (28626 MiBytes)
    3. iPXE (PCI 00:00.0)
    4. Payload [setup]
    5. Payload [memtest]

    Searching bootorder for: HALT
    drive 0x000f24d0: PCHS=0/0/0 translation=lba LCHS=499/16/63 s=503808
    drive 0x000f2500: PCHS=16383/16/63 translation=lba LCHS=1024/255/63 s=58626288
    Space available for UMB: c1000-ee800, f0000-f24d0
    Returned 253952 bytes of ZoneHigh
    e820 map has 7 items:
    0: 0000000000000000 - 000000000009fc00 = 1 RAM
    1: 000000000009fc00 - 00000000000a0000 = 2 RESERVED
    2: 00000000000f0000 - 0000000000100000 = 2 RESERVED
    3: 0000000000100000 - 00000000df14e000 = 1 RAM
    4: 00000000df14e000 - 00000000e0000000 = 2 RESERVED
    5: 00000000f8000000 - 00000000f9000000 = 2 RESERVED
    6: 0000000100000000 - 000000011f000000 = 1 RAM
    enter handle_19:
    NULL
    Booting from Hard Disk...
    Booting from 0000:7c00
    gptboot: error 1 lba 1271385
    gptboot: unable to read backup GPT header
    gptboot: error 1 lba 1269328
    //bboooott//ccoonnffiigg:: --SS111155220000 --DD

    ggppttbboooott:: eerrrroorr 11 llbbaa 11112266775522

    IInnvvaalliidd ffoorrmmaatt

    ggppttbboooott:: eerrrroorr 11 llbbaa 11112266776600

    ggppttbboooott:: NNoo //bboooott//kkeerrnneell//kkeerrnneell oonn 00::aadd((00pp33))

    FFrreeeeBBSSDD//xx8866 bboooott

    DDeeffaauulltt:: 00::aadd((00pp33))//bboooott//kkeerrnneell//kkeerrnneell

    bboooott::


  • Galactic Empire Netgate Administrator

    Can you double check if you've flashed pfSense-CE-memstick-serial-2.4.3-RELEASE-amd64.img.gz to USB drive? That output looks like you flashed VGA image instead.

    Try re-flashing it using https://etcher.io/ but make sure you're using the correct image. I'd also suggest using a different USB drive as I'm seeing disk issues.



  • @ivor The reason for this attitude is that your upgrade, straight from the gui, bricked my box. Since I have an extensive smartthings installation, I can't even turn my lights on. Basically my entire house is rendered unusable until I get this fixed. Also I work from home, so I can't work.

    So yeah, potential loss of home and livelihood due to your bugs. But yeah sure I'll tone it down. It is after all a low trust world where we're just supposed to assume that everything being broken all the time is normal.

    OK I was able to boot off a different USB stick. Thanks for the help.


  • Galactic Empire Netgate Administrator

    the reason for this attitude is that your upgrade, straight from the gui, bricked my box.

    No, that's not a reason for that kind of attitude. There's no reason for that kind of attitude, especially when asking for help.

    Since I have an extensive smartthings installation, I can’t even turn my lights on. Basically my entire house is rendered unusable until I get this fixed. Also I work from home, so I can’t work.

    None of this has anything to do with us or pfSense. Certainly not a reason to vent about it on this forum.

    OK I was able to boot off a different USB stick. Thanks for the help.

    You're welcome. Next time you have issues feel free to ask for help but keep in mind we're not here for you to vent.


Locked
 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy