Max MTU on SG-3100 LAN ports



  • I've tried setting to 9000 and saving and even rebooting but the interface status still shows 1500 MTU. I'm trying to enable 8K jumbo on the LAN side.

    Yes, I know about jumbo, had it enabled across my PC, NAS, and ASUS gateway I'm retiring. I just can't seem to get it enabled on the SG-3100.

    edit: changed WAN to LAN. I'm an idiot.


  • Rebel Alliance Global Moderator

    Are you trying to change this on the actual interface or the switch ports?



  • On the ports I assume. As stated I tried setting the LAN to 9000 but the interface status for LAN remains at 1500 and my jumbo ping tests fail. I need jumbo between the LAN switchports only, not upstream to the WAN for obvious reasons.


  • Rebel Alliance Global Moderator

    Ok I took a look on my sg-3100 and I don't think supported on the sg-3100? Maybe @jimp or @Derelict can chime in..

    If I set mtu in gui on interface igb4 on my sg-4800 sets it no problem... But if I try and set it up on interface on sg-3100 gives me error

    [2.4.3-RELEASE][admin@pfSense.localdomain]/root: ifconfig mvneta1 mtu 9000
    ifconfig: ioctl SIOCSIFMTU (set mtu): Invalid argument

    Looks like you might be limited to mtu of 1600 on this marvel stuff they are using in the sg3100? Or maybe there is something else you have to do to get that to work...

    I tired turning off checksum, since I read something about not valid with over 1600 on marvel somewhere back.. Still limited to setting to max 1600.



  • Here's an interesting symptom. I can enable jumbo on my PC and NAS devices and isolate them on a proper jumbo switch so they can bypass the netgate LAN ports and they then have an issue communicating on jumbo. If I swap out the netgate for my old jumbo-enable ASUS, it works.

    Hmmm...


  • Rebel Alliance Global Moderator

    Yeah every device on the same layer 2 would need to be using the same mtu or your going to run into problems..

    To be honest your causing yourself more grief than anything trying to use jumbo.. Might be fine on a 10ge connection from some device to a san on a dedicated layer 2 for that purpose..

    I just really see no point in a home lan what so ever, other than playing with it as experiment. Since it doesn't seem like the marvel stuff they are using in the sg3100 can go higher than a 1600 mtu.. You would be better off just moving back to standard 1500 mtu if you ask me.



  • I get the lecture every time it comes up.

    My home network is a test bench. My switches handle jumbo as did my $150 ASUS f/w. I had no problems before.

    Now I have a problem with the only equipment swap out was the f/w.


  • Rebel Alliance Global Moderator

    And like I showed you the marvel in the sg3100 can only be set to a max mtu of 1600.. Unless someone jumps in with some setting or trick that allows the the hardware being used for the interfaces and switch ports in the sg3100 to be able to use the mtu you want to use.. Its not going to work without issues.

    If you like to cause yourself grief then have fun.. Sorry but have no other advice to give.. If you want to use jumbo between your pc and nas what I would suggest is use that on the dedicated SAN between just your PC and your NAS.

    It is hindsight I know, but if your goal was to use jumbo with your sg3100 you should of prob validated with sales that it would in fact support the frame size you were looking to run.

    I am not seeing it called out as a supported feature anywhere in the docs on the sg3100

    Good luck.



  • That's the rub. It's 2018 and we still have to worry about gigabit ethernet ports/switches/chipsets having jumbo support on new equipment, especially network critical equipment.

    And there was no grief. It worked fine. It is possible to do jumbo and have all the nodes function well -- yes, it requires diligence, but I've been using jumbo for 10+ years at home without issue.


  • Rebel Alliance Global Moderator

    Well since there is no accepted IEEE standard for jumbo doesn't matter what year it is does it ;)

    With LRO and LSO kind of really pointless anyway isn't it?

    Have fun though.. Never seen any use for them to be honest - they are way more pain then they are worth that is for damn sure.



  • @johnpoz Well it's now putting a cramp in my previously-working vmware testbench (the eventual configs go into 10Gig environments but set jumbo in the vmkernel configs even though it's 1Gig). I'll have to now vlan my way around this somehow or splurge on another h/w platform for pfSense or just bite the bullet and get a PAN.


  • Rebel Alliance Global Moderator

    Lesson learned for next time you buy any hardware I guess. If your wanting to play with non standard stuff check with the maker of said hardware that your nonstand thing is supported. Even if very common.

    Sorry wish I could say oh click this, or set that - maybe there is but from what I have been reading about the marvel no not really.