DHCPv6 Server + SLAAC



  • Hi!

    I have a /56 routet prefix on my LAN interface. I've enabled the DHCPv6 server in "Assisted" mode. My clients get an IPv6 and everything works. Expect Andoird devices and Privacy Extensions because there seems to be no SLAAC.

    But why? Tought assisted means DHCPv6 + SLAAC?

    Any chance to get this running?

    igb0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=6400bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    	ether 40:62:31:00:03:a5
    	hwaddr 40:62:31:00:03:a5
    	inet6 fe80::4262:31ff:xxxx:xxxx%igb0 prefixlen 64 scopeid 0x1
    	inet 149.172.xxx.xxx netmask 0xfffffc00 broadcast 255.255.255.255
    	nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
    	media: Ethernet 1000baseT <full-duplex>
    	status: active
    
    igb2: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    	options=6500bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    	ether 40:62:31:xx:xx:xx
    	hwaddr 40:62:31:xx:xx:xx
    	inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    	inet6 2a02:8071:886:5200:4262:xxxx:xxxx: prefixlen 56
    	inet6 fe80::1:1%igb2 prefixlen 64 scopeid 0x3
    	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    	media: Ethernet 1000baseT <full-duplex>
    	status: active
    


  • The issue is that you're using a /56 on your LAN. IPv6 networks with actual devices connecting to them are not intended to be anything larger than /64. That's why SLAAC isn't working.

    The /56 might be routed to you by your ISP, but you should be breaking that down into at least one, if not multiple (up to 256), /64 networks.



  • Tought pfSense is doing this for me. I was wrong. I have it to /64 back now.