Infinite Boot after upgrade



  • I tried to upgrade my system a while back and thought it was successful, as it said it was at the newest version. I did find it odd that I had two kernels now and not just one, and had to choose the second one to boot. It had failed halfway through and I was booting to the backup.

    I tried to install a new package and it kept failing as did others. Online support instructions said to upgrade the os, so I did......and it overwrote my good backup with the invalid corrupt copy...and then it failed too. Now here I am with two corrupt kernels and an infinite boot.

    This is a new-ish install, and ironically enough, the backup package is the one I wanted, as I have no backups.

    Is there any fix for this other than a full reinstall? My entire network is down, so this is somewhat urgent. I'm not very experienced with pfsense, but I am an IT by profession (somewhat embarrassed to say that I didn't have backups prior to performing an upgrade)



  • Ok guys, I just ran a fresh install to fix this, but I've run into something else. I could only catch a glimpse of it, so not sure quite yet what the issue could be.

    Once I had my fresh install done, I tried to install a package. It came up with an error saying the package repository had a new major update. So, I again ran a system upgrade. I was on 2.3 something when I did this. Again, the upgrade failed. I notice the upgrade kernel stops when reading cpu information. When I boot again, i booted to the second Kernel, which came up and wanted to finish the upgrade. So it upgraded itself on that kernel. Now again, I have to choose the second kernel to boot, because the first is corrupt or incomplete. When I tried to install a package again, I got this error again. I look at the system stats, it says it's all up to date. I don't understand what I need to do to get all this to work. It used to be able to do package installs and updates, now my system just won't, and attempting to run an upgrade breaks it to hell and back.



  • I was on 2.3 something when I did this

    Well, it would be good to know which exact version you have installed and what version the upgrade has.
    If you did a new install anyways, why didnt you download an actual version first and install that?


Log in to reply