[Solved] Upgrade from 2.3.5 to 2.4.3 fails...



  • Enter an option: 13
    
    >>> Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    >>> Locking package pkg... done.
    >>> Upgrading pfSense-repo... done.
    >>> Unlocking package pfSense-kernel-pfSense... done.
    
    The following 188 package(s) will be affected (of 0 checked):
    
    Installed packages to be REMOVED:
            rrdtool-1.7.0_2
            php56-zlib-5.6.35
            php56-xmlwriter-5.6.35
            php56-xmlreader-5.6.35
            php56-xml-5.6.35
            php56-tokenizer-5.6.35
            php56-sysvshm-5.6.35
            php56-sysvsem-5.6.35
            php56-sysvmsg-5.6.35
            php56-sqlite3-5.6.35
            php56-sockets-5.6.35
            php56-simplexml-5.6.35
            php56-shmop-5.6.35
            php56-session-5.6.35
            php56-readline-5.6.35
            php56-posix-5.6.35
            php56-pfSense-module-0.13_1
            php56-pdo_sqlite-5.6.35
            php56-pdo-5.6.35
            php56-pcntl-5.6.35
            php56-openssl-5.6.35
            php56-opcache-5.6.35
            php56-mysqli-5.6.35
            php56-mysql-5.6.35
            php56-mcrypt-5.6.35
            php56-mbstring-5.6.35
            php56-ldap-5.6.35
            php56-json-5.6.35
            php56-hash-5.6.35
            php56-gettext-5.6.35
            php56-ftp-5.6.35
            php56-filter-5.6.35
            php56-dom-5.6.35
            php56-curl-5.6.35
            php56-ctype-5.6.35
            php56-bz2-5.6.35
            php56-bcmath-5.6.35
            php56-5.6.35
            pfSense-pkg-acme-0.3_1
            pfSense-Status_Monitoring-1.6.5
            pfSense-2.3.5_2
            nginx-1.12.2_11,2
            nano-2.9.5
            nagios-plugins-2.2.1_6,1
            mysql56-client-5.6.40
            libzmq4-4.2.3
            glib-2.50.3_2,1
            fontconfig-2.12.1_3,1
            dnsmasq-2.79,1
            bind-tools-9.12.1
            bash-4.4.19
    
    New packages to be INSTALLED:
            openvpn: 2.4.4_1 [pfSense]
            devcpu-data: 1.16 [pfSense]
            mobile-broadband-provider-info: 20170310 [pfSense]
    
    Installed packages to be UPGRADED:
            ssh_tunnel_shell: 0.1 -> 0.1_1 [pfSense]
            radvd: 1.9.1 -> 2.17_4 [pfSense]
            qstats: 0.1_1 -> 0.2 [pfSense]
            pfSense-rc: 2.3.5_2 -> 2.4.3_1 [pfSense-core]
            pfSense-kernel-pfSense: 2.3.5_2 -> 2.4.3_1 [pfSense-core]
            pfSense-default-config: 2.3.5_2 -> 2.4.3_1 [pfSense-core]
            pfSense-base: 2.3.5_2 -> 2.4.3_1 [pfSense-core]
            filterlog: 0.1_4 -> 0.1_5 [pfSense]
            filterdns: 1.0_9 -> 1.0_16 [pfSense]
            dpinger: 2.0 -> 3.0 [pfSense]
            check_reload_status: 0.0.7 -> 0.0.8 [pfSense]
    
    Installed packages to be DOWNGRADED:
            unbound: 1.7.0 -> 1.6.8 [pfSense]
            perl5: 5.26.2 -> 5.24.4 [pfSense]
            openldap-client: 2.4.46 -> 2.4.45 [pfSense]
            libunistring: 0.9.9 -> 0.9.8 [pfSense]
            liblz4: 1.8.1.2,1 -> 1.8.0,1 [pfSense]
            krb5: 1.16_1 -> 1.15.2 [pfSense]
            freetype2: 2.8_2 -> 2.8_1 [pfSense]
            cyrus-sasl: 2.1.26_13 -> 2.1.26_12 [pfSense]
            curl: 7.59.0 -> 7.58.0 [pfSense]
            clamav: 0.100.0_1 -> 0.99.4 [pfSense]
    
    Installed packages to be REINSTALLED:
            zip-3.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            xproto-7.0.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            xinetd-2.3.15_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            wrapalixresetbutton-0.0.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            wpa_supplicant-2.6_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            wol-0.7.1_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            webp-0.6.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            vstr-1.0.15_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            voucher-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            vnstat-1.15 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            unzoo-4.4_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            uclcmd-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            tiff-4.0.9_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            sudo-1.8.23_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            strongswan-5.6.2_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            sshlockout_pf-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            squidclamav-6.16 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            squid_radius_auth-1.10 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            squidGuard-1.4_15 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            squid-3.5.27_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            smartmontools-6.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            scponly-4.8.20110526_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            rsync-3.1.3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            relayd-5.5.20140810_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            readline-7.0.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            rate-0.9_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            python27-2.7.14_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            python2-2_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            popt-1.16_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            png-1.6.34 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pixman-0.34.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pftop-0.7_8 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-sudo-0.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-squidGuard-1.16.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-squid-0.4.43_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-openvpn-client-export-1.4.14 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-mailreport-3.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-iftop-0.17_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-System_Patches-1.1.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-Status_Traffic_Totals-1.2.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-Service_Watchdog-1.8.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-FTP_Client_Proxy-0.3_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-Cron-0.3.7_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pfSense-pkg-Backup-0.4_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            pcre-8.40_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            p7zip-16.02_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            p5-HTML-Tagset-3.20_1 [pfSense] (ABI changed: 'freebsd:10:*' -> 'freebsd:11:*')
            p5-HTML-Parser-3.72 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            p5-GSSAPI-0.28_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            p5-Error-0.17025 [pfSense] (ABI changed: 'freebsd:10:*' -> 'freebsd:11:*')
            p5-Digest-HMAC-1.03_1 [pfSense] (ABI changed: 'freebsd:10:*' -> 'freebsd:11:*')
            p5-Authen-SASL-2.16_1 [pfSense] (ABI changed: 'freebsd:10:*' -> 'freebsd:11:*')
            openvpn-client-export-2.4.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            ntp-4.2.8p11 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            norm-1.5r6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            nettle-3.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            mpd5-5.8_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            miniupnpd-1.9.20160113,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            minicron-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            lzo2-2.10_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            lua52-5.2.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            logrotate-3.13.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libxml2-2.9.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libucl-0.8.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libssh2-1.8.0,3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libnghttp2-1.31.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libmcrypt-2.5.8_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libltdl-2.4.6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libidn2-2.0.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libiconv-1.14_11 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libgd-2.2.4_1,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libfontenc-1.1.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libffi-3.2.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libevent-2.1.8_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libedit-3.1.20170329_2,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            libdaemon-0.14_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            ldns-1.7.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            json-c-0.13 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            jpeg-turbo-1.5.3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            jbigkit-2.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            isc-dhcp43-server-4.3.6P1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            isc-dhcp43-relay-4.3.6P1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            isc-dhcp43-client-4.3.6P1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            ipmitool-1.8.18_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            indexinfo-0.3.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            iftop-1.0.p4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            idnkit-1.0_7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            hostapd-2.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            gmp-6.1.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            giflib-5.1.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            gettext-runtime-0.19.8.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            gdbm-1.13_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            expiretable-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            expat-2.2.5 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            dnstop-20140915 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            dmidecode-3.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            dhcpleases6-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            dhcpleases-0.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            dhcp6-20080615.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            db5-5.3.28_6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            cpustats-0.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            cpdup-1.18 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            clog-1.0.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            choparp-20150613 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            c-icap-modules-0.4.5 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            c-icap-0.4.4,2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            bwi-firmware-kmod-3.130.20 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            bsnmp-ucd-0.4.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            bsnmp-regex-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            beep-1.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            ataidle-2.7.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            arj-3.10.22_7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
            arc-5.21p [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    
    Number of packages to be removed: 51
    Number of packages to be installed: 3
    Number of packages to be upgraded: 11
    Number of packages to be reinstalled: 113
    Number of packages to be downgraded: 10
    
    The operation will free 123 MiB.
    326 KiB to be downloaded.
    
    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) n
    

    ...and leaves a broken system with some libs missing.

    0_1528522886204_upgrade.JPG

    Any idea what is triggering all the php pkg's etc. to be removed, or how to stop this from happening?

    Thanks.

    /edit

    I had a little spare time to test few things.

    • restore config.xml (2.3.5) with fresh install of 2.3.5 = fail
    • restore config.xml (2.3.5) with fresh install of 2.4.3 = fail
    • edit config.xml (2.3.5) and removed the ACME package = worked in 2.3.5 and 2.4.3
    • uninstalled ACME package prior upgrading from 2.3.5 to 2.4.3 = worked

    So the ACME package was breaking the upgrade/restore, it should be obvious, because ACME depends on a php56 package, which is causing a conflict.



  • I had the same issue (https://forum.netgate.com/topic/131667/upgrade-2-3-5-to-2-4-3-crash-report/55) and eventually had to load a new image and restore config. @jimp spent a lot of time with me trying to sort out but couldn't get to the bottom of it.

    Colin



  • Got the same problem here.
    Never tried to restore since I dont know what the root PW is.
    However, I'm running on hyper-v so I simply reverted the snapshot instead.



  • I had roughly the same problem. Installation damaged by the attempted upgrade, tried all manor of resurrecting it to no avail. After most of a day wasted, just installed from scratch.

    This is exactly why I bought Netgate hardware, to avoid wasting problems chasing ghosts. But what I found is that it does not matter, Netgate did not really bulletproof the upgrade from 2.3.x to 2.4.x. If I am going to have these problems anyway, why pay the high price of their hardware?



  • The update system is quite fragile. The developers have chosen to include the pkg repository definitions as a pkg package that is the same for all supported versions of pfSense and there is no way to switch between active repositories other than going to the webgui and selecting the branch from the update settings selection box. One hickup with the system and you get all kinds of hard to solve problems like pkg suddenly no longer working.



  • @kpa said in Upgrade from 2.3.5 to 2.4.3 fails...:

    The update system is quite fragile. The developers have chosen to include the pkg repository definitions as a pkg package that is the same for all supported versions of pfSense and there is no way to switch between active repositories other than going to the webgui and selecting the branch from the update settings selection box. One hickup with the system and you get all kinds of hard to solve problems like pkg suddenly no longer working.

    The versioning problem was solved, in general, years ago. If this is the problem with pfSense then it is just laziness or ignorance. Package repositories have to be versioned to work.

    In addition, the web GUI absolutely did not work. When I selected to move from legacy to current stable, it refused to acknowledge the GUI change. When I forced it through the command line it indicated the architecture was different at first, then the next time it was different errors. The whole process was a PITA and I'll probably not buy Netgate hardware anymore. They've lost my trust.



  • @neiltiffin said in Upgrade from 2.3.5 to 2.4.3 fails...:

    @kpa said in Upgrade from 2.3.5 to 2.4.3 fails...:

    The update system is quite fragile. The developers have chosen to include the pkg repository definitions as a pkg package that is the same for all supported versions of pfSense and there is no way to switch between active repositories other than going to the webgui and selecting the branch from the update settings selection box. One hickup with the system and you get all kinds of hard to solve problems like pkg suddenly no longer working.

    The versioning problem was solved, in general, years ago. If this is the problem with pfSense then it is just laziness or ignorance. Package repositories have to be versioned to work.

    In addition, the web GUI absolutely did not work. When I selected to move from legacy to current stable, it refused to acknowledge the GUI change. When I forced it through the command line it indicated the architecture was different at first, then the next time it was different errors. The whole process was a PITA and I'll probably not buy Netgate hardware anymore. They've lost my trust.

    Oh I forgot the most important part. Each time I tried to update using the GUI, the GUI indicated as the last text string that it was successful in spite of errors it displayed earlier, then after the reboot it indicated it was still on the old version.



  • @mats It is the same user you login on gui



  • @bonsai said in Upgrade from 2.3.5 to 2.4.3 fails...:

    @mats It is the same user you login on gui

    Thanks



  • I had a little spare time to test few things.

    • restore config.xml (2.3.5) with fresh install of 2.3.5 = fail
    • restore config.xml (2.3.5) with fresh install of 2.4.3 = fail
    • edit config.xml (2.3.5) and removed the ACME package = worked in 2.3.5 and 2.4.3
    • uninstalled ACME package prior upgrading from 2.3.5 to 2.4.3 = worked

    So the ACME package was breaking the upgrade/restore, it should be obvious, because ACME depends on a php56 package, which is causing a conflict.