Duvida: Procedimento E2G + Squid Autenticado por Usuarios



  • Boa Tarde a Todos, antecipadamente agradeço qualquer ajuda.
    Senário: PFSense 2.4.3 p1 64b + Squid + FreeRadius
    Iniciando Laboratório, para remover squidguard, e instalar E2G
    Todos estão utilizando autenticação, Local Squid ou FreeRadius e alguns com Captive.

    Duvida, por favor:
    O Squid esta pronto, e autenticado no freeradius, quais as configurações que preciso fazer no E2G para ler os usuários que o squid esta filtrando?

    Testes todas as opções do [Auth Plugins] do E2G, mais na aba realtime não mostra o nome usuário apenas [ - ]
    Em Avançado Ativei a opção [Use Automatic embeded parent config] deixei default, e tambem especifiquei o ip do proprio pfsense.

    Outra duvida:
    Na opcoes da estacao, estou ativando o proxy, e colocando a porta 8080, mais a porta 3128 continua funcionando, quando pronto vou conseguir navegar apenas pela porta do E2G correto?

    Muito Obrigado



  • Para autenticação via captive e Freeradius, provavelmente o squid vai ter que continuar na frente.
    Para enviar o trafego do squid para o e2guardian, você pode configurar a aba remote proxies do squid, ou colocando estas linhas no campo Custon Options (Before Auth):

    cache_peer 127.0.0.1 parent 8080 0 login=*:password
    always_direct deny all
    never_direct allow all
    


  • Obrigado Pelo Retorno Marcelo
    Teste1:Funcionou com o Squid/FreeRadius/E2G (A Autenticação dos usuários e enviada para o E2G)
    Teste2:Nao Funcionou com PortalCaptive+Squid+FreeRadius/E2G (o e2g nao mostra o login do usuario, e mostra erro 403)

    Nas Conf. Advanced Features do Squid não fiz nenhum ajustes, esta limpa.
    Nas Conf. do E2G Informei o IP do Firewall e a Porta do Squid. Print Abaixo

    No Teste2
    Quando Desativo o E2G, volto a porta 3128 do squid, consigo navegar normalmente, e o login é mostrado na aba realtime.
    Quanto Ativo o e2g e mudo a porta da estacao trabalho para 8080, o e2g nao consegue identificar o login. Erro 403.

    Fiz os procedimentos que vc enviou, mais nao deu certo.
    Obrigado por enquanto.
    0_1529334407539_Conf. e2g.jpg



  • brastech, você teve que fazer algo para a autenticação seja enviada para o E2G ?

    Não estou conseguindo redirecionar essa autenticação.
    Utilizo o squid + E2G no mesma maquina, o firewall pfsense é em uma maquina separada.



  • @hilarioadelar, Os dois últimos posts antes do seu demonstram as duas configurações.

    A do brastech mostra a configuração com o e2guardian na frente e o post anterior mostra a configuração com o squid na frente.


Log in to reply