Issues installing on Watchguard SSL100



  • Hi everyone,

    I have a Watchguard SSL100 that I am attempting to get up and running with PFSense 2.3.5. I have a keyboard and display attached directly to the unit. When attempting to boot my 4GB SanDisk CF card which I have imaged with WinDiskImager, it hangs at the first line which is

    "BTX loader 1.00 BTX version is 1.02
    _"

    I flashed stephenw10's v8.1 BIOS as the first step, which by my understanding is derived from the SSL100 BIOS, so there should be no problem there. I attempted to revert to the backup I made of my original BIOS for troubleshooting sake but received a checksum error. I am unsure where to go from here. Any help is appreciated.


  • Netgate Administrator

    It is booting the card since you see the BTX loader so the BIOS is doing it's thing correctly.

    If you're using a monitor connected directly then the output from that point switches to serial console. Unless you're using Nano+VGA image but you would then be the only person doing so. 😉
    There is no default config for the sk/msk interfaces so it will waiting for you to assign them

    Hook up a serial console and go from there.

    Steve



  • Thank you Stephen, hooking up the serial console worked; I can now see output from the firewall. That's what I get for doing things unconventionally 😆. Unfortunately it is still not booting and is actually hanging at:

    "(ada0:ata:0:0:0:0): READ_DMA. ACB: c8 00 3f 7e 7a 40 00 00 00 00 01 00
    (ada0:ata:0:0:0:0): CAM status: Command timeout
    (ada0:ata:0:0:0:0): Retrying command"

    which it repeats ad infinitum. I assume this is some sort of corruption in my CF card. I will try re-imaging and report back.


  • Netgate Administrator

    Nope it's probably this:
    https://www.netgate.com/docs/pfsense/hardware/boot-troubleshooting.html?highlight=boot#pfsense-2-2-and-later

    The CF card slot in those boxes does not have the DMA pins connected, it can only do PIO mode. But if you use a UDMA capable CF card (most decent sized cards are) the OS will still see that and try to use it. Hence DMA errors.

    Steve


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy