J1900 Quad Will not boot pfSense



  • Hi,

    I have got hold of one of these:
    https://www.spo-comm.de/products/en/tech-quad-fanless.html

    I'm trying to install pfSense onto it. However the device keeps saying it has no boot devices. I've tried plenty of different drives in it. I'm no newbie to pfSense, have used it since it forked from monowall but this is the 1st time I've been stumped with an install.

    Interestingly when i use the memstick installer it will not boot into the installer. I have to use a USB DVD drive with the ISO to boot into the install. The install runs through ok and when it comes to reboot it just says there's no boot device on start up.

    I'm just wondering if anyone here uses one of these devices and has any experience installing PF onto it.

    Thanks, Jimmy



  • Is the SSD / HD recognised in the BIOS?



  • Yep, it appears in the BIOS. As does the memstick install. It also appears in the boot menu option.



  • SOLVED: It appears I had a bad SATA cable that was connected to an ssd with it's original OS, i had just removed the power cable to said SSD. Everything is good now



  • Great, it seems strange that it was still being recognised in the bios with a faulty cable.



  • My thoughts exactly, tested it on a freenas install after, drive worked but filled the log with CRC errors.



  • If you can put the drive into a USB 3.0 case, then test it.
    If it passes, then it might be useful for temporary backup.


  • Netgate Administrator

    I once had a desktop machine that behaved exactly like that. The BIOS would recognise and try to boot from the SATA drive but would fail every time. Turned out to be an improperly latched SATA connector. I could well believe a cable with a bad connection behaving the same. I'm guessing the data rate required to recognise the drive is far lower than actually reading data from it and can pass a high impedance connection.

    Steve



  • True, I had a problem with a internal spinner. It turned out the SATA cable was faulty.



  • SATA lead is binned now.

    What got my head in a spin with this was it would install PF to the drive but really slowly (In hindsight it took that long i should have twigged on at that point something was wrong). Once installed it just wouldn't boot from the new install. This box makes for a really good PF bar the None AES-NI CPU. However the VPNs still max out my 80/20 connection happily.

    Thanks for all your input on this one.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy