Can't access WebConfigurator to finish wizard



  • Hello,

    I hope this is the right spot to ask for help.
    After spending hours (if not days) reading, searching, trying several things, I've come to the conclusion I need help.....

    I've built a system that is going to be used as a router to replace the router from my ISP so I'm able to use OpenVPN at the router instead of on all the computers/laptops/etc. we got at home. Recently I figured out the ISP's router was hacked (they added another DNS server, next to 1.1.1.1). Got that fixed.
    I also want to run the Ubiquity Controller on the same hardware for configuring the AP's and switches.

    I've followed this YT-video. He seems to know what he is doing :)

    I've downloaded version 2.4.3-Release (pfSense-CE-memstick-2.4.3-RELEASE-amd64.img) and put it on a bootable USB-stick. I put the USB-stick into the new system and turn on the power => installing PFsense according to the manual/YT-video.
    I've assigned the WAN and the LAN using the 'a' option, no VLAN setup.
    WAN: => igb0 => v4/DHCP4: 192.168.1.23/24 (assigned by my to be replaced router which has also have 192.168.1.1 as access-address)
    LAN: => em0 => 192.168.1.1

    I've connected a laptop to the LAN and went to 192.168.1.1 (using Chrome). I got a certificate warning, ignored it, and started the wizard/setup. At step 5/9 I needed to stop (dinner).
    When I got back the laptop needed a restart (automatically shuts down after a while) and I tried to get back to the WebConfigurator.

    I couldn't! (timeout)

    I've tried 'Reset to Factory Defaults' => no result
    i've tried 'Restart WebConfigurator' and 'Restart PHP-FPM' => no result
    I've tried reinstalling PfSense (first-time option 1, second-time option 4 (ZFS)) on the new system => no result
    I've tried trying to access it using http://192.168.1.1:443 and https://192.168.1.1:80 => no result
    I've tried to run viconfig from the shell, find the "webui" section, then change "protocol" from "https" to "http" and see if could connect? => no result (reverted it back to https)
    I've tried different browsers (Chrome, Firefox) and laptops, no result.

    Other diagnostics:
    The old router sees the PfSense at 192.168.1.23
    The Laptop gets an IP-address (192.168.1.101)
    The Laptop's Network Troubleshooter indicates that it can see that 192.168.1.1 is online but does not respond to connection requests.
    Ping from 192.168.1.31 (my PC) to 192.168.1.23 does not work (request timed out)
    Ping from 192.168.1.23 (PfSense) to 192.168.1.31 (My PC) does work
    Ping from 192.168.1.101 (the laptop on LAN side) to 192.168.1.1 (PfSense LAN Side) does not work

    System:
    Mobo: AsRock Z370MITX/ac with an I3 8300, a Samsung 256GB M.2 and 8 GB DDR4.
    Why this massive overkill? We got optic fiber at 1 Gigabit, multiple users using the internet mostly for gaming, simultaneously. And I really need/want the VPN service.

    Things that makes me wonder...
    When reinstalling, the configuration files must be cleared, right? So should the 'reset to factory defaults' do.
    I thought that reinstalling PfSense would let me start with a clean sleet. Is the M.2 not cleared? What could I do to clear it?

    My background:
    I'm not familiar with FreeBSD or any Linux related stuff. Changing ViConfig? => googled it. I work in the IT as an information analyst and functional designer. Also worked as a programmer (C, C++, Java) about 12 years ago.



  • Is your wan & Lan subnet the same perhaps?
    If yes: change one of them


  • Rebel Alliance Global Moderator

    @tom17 said in Can't access WebConfigurator to finish wizard:

    WAN: => igb0 => v4/DHCP4: 192.168.1.23/24 (assigned by my to be replaced router which has also have 192.168.1.1 as access-address)
    LAN: => em0 => 192.168.1.1

    Yeah that is borked... You can not have wan and lan on same network.



  • Right.... :(
    Feeling like a Noob right now.....
    Thanks anyway!

    Removing the WAN-cable did solve the problem.
    What did I miss using the PfSense installation guide - Auto Assign Procedure? Assuming I had to connect the WAN and LAN cable and left them there....

    Question:
    During running the wizard/setup you are able to assign a LAN address. I tried to configure it for 192.168.17.1 and I got a red screen with some error message (501).
    Before replacing the current router I need to install some software (OpenVPN, Snort, etc.). I assume I need internet access to be able to do that.


  • Rebel Alliance Global Moderator

    Yeah you can change it during setup - but you have to change your clients IP to connect in on the new IP, etc.



  • @johnpoz

    Thanks for your response/pointers.

    Finally, that worked, but not as expected!
    step 5/9 => Configure LAN Interface
    Changed the default to 192.168.17.1 [next]
    step 6/9 => Change password
    Changed it [next]
    Red screen with error message:
    An HTTP_REFERER was detected other than what is defined in System -> Advanced (https://192.168.1.1/wizard.php?xml=setup_wizard.xml). If not needed, this check can be disabled in System -> Advanced -> Admin.

    I then had to reboot the PfSense-box (using ipconfig on the laptop before the reboot indicated 192.168.1.1 as the Gateway address).
    Going to 192.168.17.1 using the laptop gave me the login page where I had to use the default credentials(?).
    It did not provide me with the last couple of steps of the setup/wizard.

    Rerunning the Setup/wizard worked fine. Got a new password.

    I think there should be some kind of message indicating the potential results and extra steps needed when changing the default LAN interface.


  • Rebel Alliance Global Moderator

    There was zero reason to reboot your pfsense..

    Your error was you hit it via https.. And your getting told refer was wrong. I will run through setup here tmrw getting ready to run out to see if anything needs to be changed or should put any texted on warning if changing IP on a normal config.



  • @johnpoz

    I really appreciate you are helping me and a lot of others, so it seems, who are having challenges setting up there PfSense software or trying to configure certain things.
    Really, I do!

    But......

    Being a Noob (obviously) with this PfSense software and not fully understand everything I still try to figure out this stuff and try to get it to work myself using the little knowledge I have with these kind of things. So....
    If I use ipconfig to determine the address of the gateway, both before and after I reconnect the laptop with the PfSense LAN-port and I still see: 192.168.1.1;
    If I try a new browser-tab and try to connect with 192.168.17.1 and get a TimeOut error (again);
    .....
    I reboot the PfSense as a last resort.

    I merely described what I've done to get it working again. Perhaps there are others (Noobs) who ran into similar problems. It's my way to give back!
    I truly hope you'll understand this.

    Still...
    What should I have done?


  • Rebel Alliance Developer Netgate

    @tom17 said in Can't access WebConfigurator to finish wizard:

    An HTTP_REFERER was detected other than what is defined in System -> Advanced (https://192.168.1.1/wizard.php?xml=setup_wizard.xml). If not needed, this check can be disabled in System -> Advanced -> Admin.

    That was a bug, we fixed that recently, and the fix will be in the next release. See https://redmine.pfsense.org/issues/8524


  • Rebel Alliance Global Moderator

    Great... I was meaning to play with this but have been side tracked all weekend.