Absolute beginner: not coming further after cd booting



  • I've downloaded and burned the pfsense 1.0 beta 4 to a cd rom. My intention is to install it on the hard drive of an old Pentium 100 to work as a router/firewall. After booting the cd, I'm stuck with a very simple problem, which has yet been unsolvable: how do install pfsense on my hard drive. After a pretty long booting time (FreeBSD loading) I get a command prompt and I find myself in the /root directory. What should I do?

    I tried of course to look for documentation and posts in this forum, but couldn't find the answer (checked FAQ + m0n0wall documentation). Would be grateful for help.



  • Something is wrong with your hardware.  It should not end up with a root prompt, it should end up with a console menu with options 1-12 and 99.



  • Either this or something is wrong with your CD. Try redownloading the image and reburning.



  • I first get a menu with 7 different options. Typing 99 does not help.

    When I do nothing, it loads FreeBSD and I end up with a command prompt. I cannot of course be sure, if something is wrong with my hardware, but the hard drive is brand new and I have already managed to install OpenBSD without error messages on the same computer.

    Can it be that I have somehow the wrong CD image? In any case, I'll try downloading the CD image again tomorrow, unless you have some other suggestion.



  • This is just before it boots up to choose some options. This is not the menu we are talking about. The menu will be presented AFTER it has completely booted up.

    See http://doc.pfsense.org/index.php/Chapter_3:_Installing_pfSense to get a thought how it should look like.



  • I tried creating another cd, this time burning it as slow as Nero allowed (8x). Same result.

    After the aformentioned FreeBSD menu it loads a while, then comes a funny melody through the PC speaker and the following text

    [size]
    Welcome to pfSense BETA4 on the 'cdrom' platform
    
    md0.unzip: 1535 x 65536 blocks
    Generating MFS /var partition
    Generating MFS /etc partition
    Generating MSR /root partition
    Looking for pfi.conf on acd0c done.
    Looking for pfi.conf on fd0 done.
    Looing for config.xml on df0 GEOM_LABEL: Label msdosfs/SMART BTMG removed.
    [found msdos] done.
    Generating a MFS /conf partition... done.
    Mounting filesystems... done.
    pid 109 (php), uid 0, was killed: out of swap space
    Killed
    Starting CRON... done.
    Bootup complete
    
    FreeBSD/i386 (Amnesiac) (ttyv0)
    
    %
    [/size]
    
    

    Could the error be in the line

    
    pid 109 (php), uid 0, was killed: out of swap space
    
    

    ? If yes, what could be causing it? If you suspect a hardware incompatibility, can I turn on logging or do something else to verify this?



  • Yes. pfSense requires 128 megs of ram.



  • Thanks. I should have read the hardware requirements before trying to install it. I'll then get some better hardware and try again.


Log in to reply