Install from nightly build not working



  • I got an unsupported motherboard that has X553 NIC on it. I've worked very hard to get it to work. I tried to install the night build by writing the image to a usb drive and then trying to boot the image on my motherboard, but I was always having a UEFI error.

    FreeBSD EFI boot block
            Loader path: /boot/loader.efi
    

    I had to go back to the released version 2.4.3, install a temporary nic to be able to boot it and set it up and then from the WebUI upgrade to dev branch. Then re assign the interfaces to the newly discovered integrated nic, then halt the system and finally remove the temporary nic.

    Anyways, I don't know if it's by design that the nightly builds doesn't include the efi portion or not. I just wanted to share my experience using it.

    Motherboard is : Supermicro A2SDi-4C-HLN4F
    Note, in case someone doesn't read entirelly: This motherboard is not going to work with version 2.4.3, only version 2.4.4 and above will work.
    Note 2 : It does work with the DEV branch, follow above instructions
    Note 3: BIOS is set to defaults (so UEFI), I only changed the boot order

    Here is my setup
    Motherboard : Supermicro A2SDi-4C-HLN4F
    Memory : Kingston KVR24N17S6/4
    SSD SATA DOM : Supermicro SSD-DM016-SMCMVN1
    Case : Supermicro SC505-203B
    I/O Shield : Supermicro MCP-260-00085-0B

    This setup is going to be awesome once 2.4.4 get released until then I'll have no choice but to use the dev and hope for the best!

    I'm using pfSense from it's early begining, I just checked the possible versions and my memory tells me that I'm using it before 1.2, but the doc does not list any version prior to that, so I my memory must be wrong... I had to create a new account but here is my first post on the forum 10 years ago https://forum.netgate.com/post/174262


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy