IPv6 - No Address on WAN?



  • Hi there,

    Please forgive me.. I've tried so many different settings, and nothing has worked except once I was able to get an IPv6 address on the WAN side (and was able to ping6 google.com), and while trying to get it to work on the LAN side suddenly it stopped working.

    I'm relateively new to pfSense (okay, I just started using it 2 days ago), and fairly new to BSD aside from macOS but knowledgeable with Linux in general.

    Anyway, I'm wondering if it's a problem with my settings or if there is something actually wrong with services running on my router. I did find a page that suggested using the shell to check the process list for dhcp6c running twice (in my case it wasn't running at all?). I've tried checking around in /var/log/ but I can't find anything that would indicate by it wouldn't be running.

    Another thing I'm wondering is if I modify the IPv6 settings for the WAN, what do I need to do to get them to take effect? Do I just have to apply them? Release/renew the WAN IP? Reboot? I ask because if I change the IPv4 LAN IP as an example, the WebGUI is completely useless until the computer is rebooted from the shell.

    Thanks in advance!



  • @xero9 I'm in a similar boat. In most cases, I've just applied the changes through the webGUI. Sometimes, I'll release and renew the DHCP through the webGUI. On occasion, I've taken disabled and re-enabled the interface in the GUI to ensure that I've forced a reset (though this is probably overkill). I haven't had to reboot the machine.
    Are you able to consistently get an address on your WAN? Something starting with 2600:, probably? It will always have an address starting with fe80: