After upgrading to 2.4.3_1, package manager fails with "pkg-static: No trusted certificates"



  • The full text of the error, which occurs when trying to install or upgrade any package, is as follows:

    Updating pfSense-core repository catalogue...
    pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    Fetching meta.txz: . done
    pkg-static: No trusted certificates
    repository pfSense-core has no meta file, using default settings
    Fetching packagesite.txz: . done
    pkg-static: No trusted certificates
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    Fetching meta.txz: . done
    pkg-static: No trusted certificates
    repository pfSense has no meta file, using default settings
    Fetching packagesite.txz: .......... done
    pkg-static: No trusted certificates
    Unable to update repository pfSense
    Error updating repositories!
    Failed
    

    Any ideas what may have happened or how to resolve?


  • Rebel Alliance Developer Netgate

    What version were you running before the upgrade?
    Can you post the contnet from /conf/upgrade_log.latest.txt?