LAN Interface Down/Unreachable



  • Hello everyone,

    I am relatively new to pfSense, I do have some experience with it in a virtualized format when I was running it as a VM on my homelab server. It seemed to work fine on that format, and I wanted to expand the usage to cover my home network. I purchased a purpose-built box (https://www.amazon.com/gp/product/B06ZYG5ZQX/), loaded pfSense, and am having some issues that I can't seem to resolve.

    After loading pfSense, I began the configuration however it seems no matter what ethernet interface I use for LAN, I am not able to connect to the webConfigurator, and cannot ping or otherwise connect to the box. The interface is always shown as "down" on the interface I assign to LAN, and it doesn't appear to matter which interface I use.

    When assigning any of the interfaces to WAN, the box will successfully get an address from my cable modem through DHCP. The modem is in pass-through and would normally then connect to my WiFi router.

    I have tried disabling the firewall, changing from HTTPS to HTTP for the configurator as well as forcing mismatched protocols as seen here, tried the relevant steps here, checked this documentation, and reviewed many, many slightly related posts but none seemed to have the problem I'm having. I have also tried plugging the box into my WiFi router, plugging into a switch of its own directly to one of my computers, and plugging it straight into one of my computers. I've tried setting the LAN IP up with and without DHCP enabled as well.

    It seems like there should be no issue getting to the configurator.

    This may be the key indicator, I'm just not sure what to do to fix it, but I hooked the box up to one of my managed switches (layer 2 "plus") so I could see if any data was passing and there is data being sent to the port the box is on, however, no data is seen coming back from it.

    As for the addressing, my home network is of course 192.168.1.0/24, my WiFi router is acting as DHCP server for the range 192.168.1.1-192.168.1.98, and I have tried multiple static IPs outside of the DHCP range

    Ultimately I want to run the pfSense box as a bridge/edge-firewall rather than using it as a router or for any other services within my home network and retain the ability to manage all of that through my other devices.

    If you see something glaringly wrong or have any advice or leads, please let me know! I'm banging my head on my desk right about now



  • Ok guys, I know this is going to kill any credibility I might have ever had but....the interface names, and places on the motherboard did not line up... So I was using igb0 (first port from left) for WAN, igb1 (second port) for LAN, and igb2 (third port) for OPT1. It turns out, port 1 is igb0, port 2 is igb2, and port 3 is igb3. I figured it was 0 1 2 3.

    I discovered this by using the "auto-assignment" feature, I never thought that the numbers wouldn't be sequential.

    And thus, I am now able to access the webConfigurator. Lesson of the day: Don't trust random almost no-name Chinese MFGs to make everything sensical.

    I'm adding this post for posterity to make sure they remember to chickity check themselves before they spend 8 hours troubleshooting what seems like an insane problem.

    Also I found this document at some point to help me achieve what I want to for my pass-through style: http://users.ox.ac.uk/~clas0415/assets/Setting-up-pfSense-as-a-Stateful-Bridging-Firewall-with-commodity-hardware.pdf


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy