DynDNS broken for me



  • Hi,

    since the past 2 Versions I'm suffering from issues with DynDNS not updating. I'm using All-inkl.com as DynDNS provider and in the past I used a custom config which was working fine most of the times. Now, since there is a pre configured Template for All-inkl.com this does no longer work constantly.
    I got a workaround of using a custom template and the All-inkl.com Template. Most of the Times at least one of the Templates manage to update the DNS.
    If I run either of the templates manually they always work.

    Any advice ?



  • bump
    Is there none having an Idea on how to troubleshoot this ?



  • @satras If they always work when run manually then there is something wrong with the scheduler/Cron? Perhaps the time you have schedule it, the server is always on maintenance?


  • Netgate

    You can always run the custom config with the old settings that worked, see what might be different, and report a bug in the all-inkl template.



  • @sammywoo said in DynDNS broken for me:

    @satras If they always work when run manually then there is something wrong with the scheduler/Cron? Perhaps the time you have schedule it, the server is always on maintenance?

    Thanks, where do I change the Schedules ?Can't find this setting anywhere.

    @derelict said in DynDNS broken for me:

    You can always run the custom config with the old settings that worked, see what might be different, and report a bug in the all-inkl template.

    Both, the custom config and the all-inkl template do behave equaliy now. So it does not matter which one I got active, both fail these days (or as SammyWoo said won't even try to update?).

    Till now, when I had both Active, at least on usally worked, but the last few days this is no longer true.
    I have to manuially rtun one to get my DynDNS updated.

    Thanks to both of you, much appreciated. I'm absolutely clueless.



  • I think I got it.
    I've installed the Cron package and checked. Looked like it was set to 1 1 * * * or so.
    Which made it only run once at 1 Minute past one each day ?

    I've set it to run every 15 minutes */15 * * * *

    Should be ok ?



  • Yepp, this fixed it.
    Not sure if I should run it every 15 minutes ?

    I was thinking that there is some automatism in pfSense to run it whenever the wan IP changes. But Cron does it as well :)


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy