Can't get pfsense to boot on a HP T620 Plus



  • I made a bootable USB installer with this:

    https://nyifiles.pfsense.org/mirror/downloads/pfSense-CE-memstick-2.4.3-RELEASE-amd64.img.gz

    The HP T620 Plus has a 32GB SanDisk USB 3.0 stick in an internal USB 2.0 port. I can boot the USB installer no problem (in a external USB 2.0 port), and the install process with default options completes fine. At the end, it asks if I want to do any manual steps in a shell (answered no), and then reboot. remove the usb installer, leaving only the 32GB stick in and the system says "no boot device detected".

    in another forum, another person with the same machine says they got pfsense installed and booting without any issues, but I can't see how this is possible given my own experience so far? this machine's BIOS can boot both UEFI and legacy. in it's default settings, it tries any UEFI bootable devices first, and the tries any legacy bootable devices. the 32GB stick shows up in the legacy listing.

    i've reset BIOS settings back to factory defaults. I've check secure boot is disabled. i've tried to manually select the 32GB usb stick from boot menu, and it will not boot. i've tried using several other USB sticks as boot drive with same result. i've tried using different USB port with same result.

    i've spent several hours searching online and asking folks in another forum who successfully booted pfsense on this machine and have found no solution. very frustrated. just as a test, to see if the problem is hardware related, I installed CentOS 7 on at least 2 of the USB drives I've tried to install pfsense on, and CentOS 7 boots up fine; zero issues whatsoever. retry and re-install pfsense, and "no boot device detected."

    please help...



  • UPDATE: finally got pfsense to boot, but only if I choose ZFS/root option. This makes the boot drive appears as a UEFI bootable source, and that seems to boot fine. Choosing the UFS option, the system does not boot.

    Does that provide more information to narrow down the root cause of why UFS installation will not boot on this machine?


  • Netgate Administrator

    There does appear to be an issue I have seen a couple of times. The auto installer, when you select UFS, seems to choose which boot loader to install based on how it was booted itself. The installer image can boot both legacy or UEFI.
    The only way currently to override that is to choose ZFS and then select the partition scheme either GPT(UEFI) or GPT (BIOS+UEFI).

    Thus on your system if the installer image is shown as legacy I would expect it to install the legacy partition scheme and not be UEFI bootable with UFS. But your box should be able to boot that.

    You might try forcing the installer to boot UEFI if you need UFS.

    Steve



  • @stephenw10 how does one force the installer to boot UEFI?

    When I chose ZFS/root, it did not give me any choice about GPT though... i just started copying files and installed...

    Also, the BIOS on this system can boot "legacy" BIOS as well, and I've been able to boot CentOS-7 on a USB drive that way. Why is it that pfsense installed as legacy boot won't boot then?


  • Netgate Administrator

    Indeed I would still have expected it to boot.

    When you boot the installer choose 'guided ZFS'. Then on the next screen you can choose the partition scheme.

    Pretty sure it's GPT (BIOS+UEFI) by default though, which is why it did then boot.

    Steve



  • @stephenw10 you were right... when i used the boot selection menu, and boot the installer with UEFI, the installation boots afterwards. I was letting it auto-select the 1st bootable option, which might have been trying to boot the installer with legacy BIOS.