Restoring config from beta releases



  • Hi

    I searched but could not find a solution in the forums...

    I have an issue with the current beta releases and have for some days now tried to restore the config from a Netgate appliance APU30 that are in latest beta (2.4.4.a.20180707.1723) to a VMWare virtual installation running beta 2.4.4.a2018.0707.0234. (Why it is beta release at all I do not know but it is what it is...)

    The VMWare installation refuse to take the config from the Netgate device: "The configuration could not be restored".

    I am also a bit surprised why I can't get them to be on the exact same beta version as they both are AMD64 installations. Both show upgrades but not to the exact same version.

    Any ideas?


  • Netgate Administrator

    If it's an actual Netgate appliance (APU30 is not a model number we've ever used) it will probably be pulling from the factory repo so it will have a different build number to the CE image built against the same code. That should not prevent you restoring the config though.

    Check the system log for errors reported when you try to import it.

    Steve



  • Sorry it is a APU4-30.

    Ok, I will check the logs


  • Netgate Administrator

    Ah, Ok. That is probably in fact the first generation APU model with 4GB RAM and a 30GB SSD.
    It may well be running the factory image.

    The config should still restore fine into a VM. Especially since they will both be running the same config version.

    Steve



  • In the web based logs in Status -> System logs I get nothing new after trying the import.
    Or am I looking in the wrong place?


  • Netgate Administrator

    Hmm, no that's where I might expect it.

    You might also check /cf/conf/upgrade_log.txt though without actually starting an upgrade I don't expect to see anything there either.

    Is there anything special about your APU config?
    It errors out before asking you to reassign the interfaces?

    Steve



  • Squid installed but disabled. 5-6 VLAN configured....

    The backup is the standard backup from the APU with no encryption.
    On the just factory reset pfsense VM (150gb/2Gb/2NIC) I select the restore file and hit the restore button and the error message comes immediately. No attempts for interface settings.

    I did the same some weeks ago but from a APU with stable release. No problem at all....


  • Netgate Administrator

    Hmm, it doesn't seem to be a general regression, I am able to backup and restore configs locally.

    Can you try backing up and restoring a config from the VM?

    Or restoring the same config back into the APU? There may be some risk involved there.

    Steve



  • I solved it
    The backup file came from version 2.4.4.a.20180707.0234 on an APU4-30G. I found this in the end of the exported XML backup file from the APU:

    <script type="text/javascript">CsrfMagic.end();</script>

    This is apparently a common problem a bit here and there in PFSense I can read, with garbage in config files.

    Happy days!....


  • Netgate Administrator

    Hmm, that's the first time I've ever seen that.
    If that's a common problem we need to fix it. How exactly were you getting the config file from the APU?

    Steve