How do I set up a Router behind pfSense to use the WiFi of that Router ..



  • Hey,

    I have a Linksys Router hear at home and I'm wanting to use the WiFi from the Router behind my pfSense Box. Does anyone know how to do this.

    Do I connect the Router directly to my pfSense Box or connect it to the switch and do I connect Via. the WAN or LAN interface on the Linksys Router.

    I'm not sure how to get the Address for the Router as pfSense is 192.168.1.1.

    If I use the Router for the WiFi, does anyone know how I do this.


  • Rebel Alliance



  • Hey, thanks for your reply.

    I have my ISP Box connected in Bridge Mode to my pfSense Box. My pfSense Box is connected threw LAN interface to my Linksys Router and my Router to my switch.

    I do not know how to get access to the Linksys Router to switch off DHCP as when I type 192.168.1.1 in too my browser it brings up the Web Config for pfSense .

    My set is this.

    ISP Box > pfSense Box > Linksys Router > Switch > Home PC's ..

    I have my Wan from ISP Box to pfSense and LAN from pfSense Linksys Router. LAN from Linksys Router to switch.

    How do I get access to LInksys Router. I am currently using two of the four Ethernet Ports on the LInksys and by the looks of it. Its just passing threw the traffic.

    Thanks.


  • Rebel Alliance

    Do you know the "Linksys" LAN IP address ?

    Unplug/remove it from you "Network/LAN" and connect a PC/Laptop directly to one LAN port of the "Linksys" and make the Changes suggested at the "Doc" then reconnect it to your "Network/LAN"

    I would do:

    ISP Box > pfSense Box > Switch > Home PC's .

    and one of the Linksys Router LAN post connected to the Switch



  • Hey,

    I've been at this for the last two hours.

    I'm some what getting some were. I have managed too dissconect all of the Linksys equipment from my LAN Network and connect it directly to my desktop.

    I have logged in to the Linksys Router and have changed the DHCP to disabled. I have disabled the firewall and changed the default I.P Address of the Linksys from 192.168.1.1 to coincide on my pfSense LAN.

    I have plugged the Linksys directly back in to the Switch and have the Ethernet LAN connected to the Switch and from what I can tell the WiFi is working fine.

    I don't have a face-book account but I have been able to load the face-book web page as a test page on my android smart phone using the WiFi after disabling the DATA on said phone.

    My set up looks like this:

    ISP Box > pfSense Box > Switch > PC's

    Linksys connected to the Switch with DHCP and Firewall disabled.

    I'm still unable to get access to the Linksys on my LAN after changing the Internal I.P Address from my browser.

    It was a nightmare getting access to it from my desktop because despite being connected directly it was loading the Web-Config on 192.168.1.1 .

    I have changed it too 192.168.1.2 but its still not loading.

    I'll do some more configuring later to see if I can access so I dont have too keep unplugging things but for now the WiFi seems ok.

    Thanks a lot.


  • Netgate

    If you were using a real access point you could set a default gateway there.

    You likely have to set outbound NAT so the connection to the AP appears to be coming from something on its LAN subnet and not a foreign subnet it doesn't know how to route back to.

    The workaround will be very similar to this:

    https://www.netgate.com/docs/pfsense/highavailability/troubleshooting-vpn-connectivity-to-a-high-availability-secondary-node.html



  • I would have too disconnect all the equipment and set it up again in order to do this. Rout back to the Linksys.

    Will this be a problem do you know if I leave it the way it currently is.

    I set this up so I could use this in conjunction with another project I'm currently doing which is using a Satellite dish to amplify the WiFi signal of the Linksys Router to broadcast across a large area and out side my home.

    I bought a satellite dish from amazon along with the tri-pod and I currently have the Linksys sitting in front of the sat dish on the tri-pod to amplify the signal as far out as possible.

    The sat dish is not omnidirectional but so far I have not encountered any problems and I'm able to set up and use the WiFi as normal.

    I disabled the firewall and DHCP because obviously DHCP had to be but I was not sure about the firewall as when I had got this previously set up I couldn't connect but this time it seems to be working.

    If I log back in to the router by connecting it directly to the desktop and change NAT to outbound or something similar in the set up. Would this provide a way to log in via the browser to the web config on 192.168.1.2 as pfSense is 192.168.1.1 ..

    Thanks.



  • @thehermit

    I'm not sure where your problems are coming from. With almost any router/AP, as soon as you connect the LAN side to your network, the AP is on the network and should function as expected. As mentioned above, you should turn off the DHCP server, so that it doesn't try to hand out addresses. Just assign an address, subnet mask etc., for your network and it should be fine.


  • Netgate Administrator

    Mmm, that should work just fine.

    If wifi clients are receiving DHCP from pfSense correctly and can connect out then you have it connected correctly.

    If you cannot access the router directly in 192.168.1.2 it's most likely because it has no route back. Did you set the correct subnet mask in the router?

    Steve



  • The cable from pfsense should be plugged into the "Internet" connection on the Linksys. A recommendation is to make sure the network name (ssid) and password in the Linksys is set to your preference before setting the type of internet connection to bridge.

    Not sure what kind of Linksys router you have, but if it is any of the consumer products, you should log in to the interface of the linksys, go to "Connectivity" and then "Internet Setting". In that particular menu, you can edit the "Type of internet connection" from 'DHCP' to 'Bridge mode'. This mode disables everything except the wireless access point.

    I have just done the same (setting up pfsense and re-configuring my linksys router to be an access point and switch only).