HAproxy + 2.4.4-DEVELOPMENT (amd64) built on Mon Jul 09 16:03:52 EDT 2018



  • Hello,

    After the latest upgrade to php7 in the new update package it gives you this error:

    Crash report begins.  Anonymous machine information:
    
    amd64
    11.2-RELEASE
    FreeBSD 11.2-RELEASE #35 79c8a561b61(RELENG_2_4_4): Mon Jul  9 16:25:18 EDT 2018     root@buildbot3:/builder/ce-master/tmp/obj/builder/ce-master/tmp/FreeBSD-src/sys/pfSense
    
    Crash report details:
    
    PHP Errors:
    [10-Jul-2018 04:20:23 Etc/UTC] PHP Fatal error:  Uncaught Error: [] operator not supported for strings in /usr/local/pkg/haproxy/haproxy.inc:1620
    Stack trace:
    #0 /usr/local/pkg/haproxy/haproxy.inc(2362): haproxy_writeconf('/var/etc/haprox...')
    #1 /usr/local/pkg/haproxy/haproxy.inc(1228): haproxy_check_run(1)
    #2 Standard input code(5): haproxy_configure()
    #3 {main}
      thrown in /usr/local/pkg/haproxy/haproxy.inc on line 1620
    [10-Jul-2018 04:22:24 Etc/UTC] PHP Fatal error:  Uncaught Error: [] operator not supported for strings in /usr/local/pkg/haproxy/haproxy.inc:1620
    Stack trace:
    #0 /usr/local/pkg/haproxy/haproxy.inc(1234): haproxy_writeconf('/var/etc/haprox...')
    #1 /usr/local/www/haproxy/haproxy_global.php(91): haproxy_check_and_run(NULL, true)
    #2 {main}
      thrown in /usr/local/pkg/haproxy/haproxy.inc on line 1620
    [10-Jul-2018 04:23:36 Etc/UTC] PHP Fatal error:  Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/haproxy/haproxy.inc:2722
    Stack trace:
    #0 /usr/local/pkg/haproxy/haproxy.inc(910): get_backend_acls(Array, 'http')
    #1 /usr/local/pkg/haproxy/haproxy.inc(1944): write_backend('/var/etc/haprox...', Resource id #74, 'VestaHTTP_http_...', Array, Array)
    #2 /usr/local/pkg/haproxy/haproxy.inc(2223): haproxy_writeconf('/var/etc/haprox...')
    #3 /usr/local/pkg/haproxy/haproxy.inc(592): haproxy_check_run(1)
    #4 /etc/inc/pkg-utils.inc(748) : eval()'d code(1): haproxy_custom_php_install_command()
    #5 /etc/inc/pkg-utils.inc(748): eval()
    #6 /etc/inc/pkg-utils.inc(835): eval_once('haproxy_custom_...')
    #7 /etc/rc.packages(74): install_package_xml('haproxy')
    #8 {main}
      thrown in /usr/local/pkg/haproxy/haproxy.inc on line 2722
    [10-Jul-2018 04:24:54 Etc/UTC] PHP Fatal error:  Uncaught Error: [] operator not supported for strings in /usr/local/pkg/haproxy/haproxy.inc:1620
    Stack trace:
    #0 /usr/local/pkg/haproxy/haproxy.inc(2362): haproxy_writeconf('/var/etc/haprox...')
    #1 /usr/local/pkg/haproxy/haproxy.inc(638): haproxy_check_run(1)
    #2 /etc/inc/pkg-utils.inc(748) : eval()'d code(1): haproxy_custom_php_install_command()
    #3 /etc/inc/pkg-utils.inc(748): eval()
    #4 /etc/inc/pkg-utils.inc(835): eval_once('haproxy_custom_...')
    #5 /etc/rc.packages(74): install_package_xml('haproxy-devel')
    #6 {main}
      thrown in /usr/local/pkg/haproxy/haproxy.inc on line 1620
    [10-Jul-2018 04:24:58 Etc/UTC] PHP Fatal error:  Uncaught Error: [] operator not supported for strings in /usr/local/pkg/haproxy/haproxy.inc:1620
    Stack trace:
    #0 /usr/local/pkg/haproxy/haproxy.inc(2362): haproxy_writeconf('/var/etc/haprox...')
    #1 /usr/local/pkg/haproxy/haproxy.inc(1228): haproxy_check_run(1)
    #2 Standard input code(5): haproxy_configure()
    #3 {main}
      thrown in /usr/local/pkg/haproxy/haproxy.inc on line 1620
    
    
    No FreeBSD crash data found.
    

    Anyone that might have a "quick fix" for this error, until it haproxy gets updated to the php7?





  • Yep, fix on its way.. thats the idea at least 😃 .


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy