arpresolve: can't allocate llinfo for [wanip] on igb1



  • I'm not happy with the title of this thread, but it's at least a start. I've also changed my actual wan ip in the title to that placeholder. This is a bit rambling, so I apologize.

    This morning, I noticed that my NTP Status widget was once again without a server/time. This happened about 4 days ago, too. I rebooted the pfSense box and everything came up fine. I checked Status > Monitoring and it looks like NTP started having issues about 11:30 am yesterday and stopped at about 1:30 pm. I never noticed an issue until this morning since everything was (apparently) running fine.

    I checked my cable modem's (Arris SB8200) Event Log and it looks like it rebooted around 11:30 am yesterday.

    Looking at Status > System Logs (filtered by a subset of my wanip), I see:

    Jul 9 11:36:09	rc.gateway_alarm	82006	>>> Gateway alarm: WAN_DHCP (Addr:[wanip] Alarm:1 RTT:7747ms RTTsd:4124ms Loss:22%)
    
    Jul 9 11:37:47	kernel		arpresolve: can't allocate llinfo for [wanip] on igb1 (many of these)
    
    Jul 9 11:38:18	php-fpm	24156	/rc.newwanip: IP Address has changed, killing states on former IP Address [wanip].
    
    Jul 9 11:38:20	kernel		arpresolve: can't allocate llinfo for [wanip] on igb1 (many of these)
    
    Jul 9 11:39:18	php-fpm	24156	/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - [wanip] -> 192.168.100.11 - Restarting packages.
    
    Jul 9 11:39:21	kernel		arpresolve: can't allocate llinfo for [wanip] on igb1 (many of these)
    
    Jul 9 11:39:38	php-fpm		/rc.linkup: ROUTING: setting default route to [wanip]
    
    Jul 9 11:39:39	php-fpm	49335	/rc.newwanip: rc.newwanip: on (IP address: [wanip]) (interface: WAN[wan]) (real interface: igb1).
    
    Jul 9 11:39:39	php-fpm	49335	/rc.newwanip: ROUTING: setting default route to [wanip]
    
    Jul 9 11:39:46	php-fpm	49335	/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 192.168.100.11 -> [wanip] - Restarting packages.
    

    So, I assume the cable modem's reboot kicked this off.

    From the above log entries, it looks like pfSense noticed the problem with the WAN, killed the states, reset my WAN to a local address (192.168.100.11), reset the WAN to a real wanip when the cable modem came back, set the default route correctly, and restarted packages. It looks like everything was happy with that except the NTP server which never recovered until I rebooted pfSense.

    Looking around the internet, I found a year old similar thread:

    https://www.reddit.com/r/PFSENSE/comments/534nra/pfsense_looses_connection_after_comcast_outage/

    The solution, there, is to add my cable modem's address (192.168.100.1) to the "Reject leases from" field of Interfaces > WAN > DHCP Client Configuration to stop pfSense from getting a lease from the cable modems DHCP server when it can't get one from my ISP (there's no way to turn off the SB8200's DHCP server).

    So, finally, my question: is this still a valid way to correct this issue? Also, shouldn't the NTP server have restarted with everything else and started looking at the correct wanip and default route?


  • Netgate Administrator

    Yes, that's still a valid solution to prevent the cable modem giving you a local IP.

    Steve



  • Thanks. Hopefully, that will keep NTP running, too.

    EDIT: Never mind this paragraph. I found the log entry about states being killed. OP: As far as I can tell, pfSense killed the states on the former IP address when it noticed the first change to the wanip. But, I don't see it killing them when the wanip changed to a valid one. It's possible I'm missing it in the logs, but shouldn't it have done so?


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy