Can i install dig,whois,nslookup on my 1.2.3



  • i´m running 1.2.3-PRERELEASE-TESTING-VERSION

    would be nice to have them, is that doable?

    /F



  • I have the same problem !



  • You can install any FreeBSD package for the underlying version of FreeBSD - search the forum for details.  Be aware that this is unsupported and you're on your own if it causes problems.



  • I`ve tried pkg_add -r whois, it goes well but when i write whois in the shell it tell me command not found.


  • Rebel Alliance Developer Netgate

    @Kronyx:

    I`ve tried pkg_add -r whois, it goes well but when i write whois in the shell it tell me command not found.

    Did you logout and back in after doing this? Or type "rehash"? The shell in pfSense doesn't automatically find new executables in the path unless told to do so, or upon login.

    I believe dig is a part of bind, which would be a lot of crud to install. Consider using the "drill" and "host" packages instead. "host" is a quick and easy check, drill is somewhat like dig but it is also dnssec aware.



  • I`ve tried:

    rehash

    whois

    whois: Command not found.

    then:

    pkg_add -r whois

    finally:

    Reboot, still not working


  • Rebel Alliance Developer Netgate

    Looks like that installs as mwhois, not sure why:

    # grep bin /var/db/pkg/whois-4.7.22/+CONTENTS 
    bin/mwhois
    # mwhois
    Usage: whois [OPTION]... OBJECT...
    
    -l                     one level less specific lookup [RPSL only]
    -L                     find all Less specific matches
    -m                     find first level more specific matches
    -M                     find all More specific matches
    -c                     find the smallest match containing a mnt-irt attribute
    -x                     exact match [RPSL only]
    -d                     return DNS reverse delegation objects too [RPSL only]
    -i ATTR[,ATTR]...      do an inverse lookup for specified ATTRibutes
    -T TYPE[,TYPE]...      only look for objects of TYPE
    -K                     only primary keys are returned [RPSL only]
    -r                     turn off recursive lookups for contact information
    -R                     force to show local copy of the domain object even
                           if it contains referral
    -a                     search all databases
    -s SOURCE[,SOURCE]...  search the database from SOURCE
    -g SOURCE:FIRST-LAST   find updates from SOURCE from serial FIRST to LAST
    -t TYPE                request template for object of TYPE ('all' for a list)
    -v TYPE                request verbose template for object of TYPE
    -q [version|sources|types]  query specified server info [RPSL only]
    -F                     fast raw output (implies -r)
    -h HOST                connect to server HOST
    -p PORT                connect to PORT
    -H                     hide legal disclaimers
          --verbose        explain what is being done
          --help           display this help and exit
          --version        output version information and exit
    


  • Thanks a lot !

    BTW I've tried to make an alias in my .profile

    alias whois='mwhois'

    but it's not saving, is there somewhere else that i should save that ?



  • I've edited the .profile and added this line:

    alias whois=mwhois

    But when i logout en login back the whois command is not working, is there something i'm doing wrong ?

    thanks for your help.


  • Rebel Alliance Developer Netgate

    .profile won't work, as that's used on login to drop you into the menu. When you press '8' is launches another instance of tcsh, which should read .tcshrc

    So if you add this to .tcshrc, it should work:

    alias whois mwhois
    

    The syntax is slightly different than what you posted, too.

    That worked for me. :)



  • Thanks a lot for your help !


Locked