How to scroll the backup restore list?



  • Basic question: I lost the webgui IP link, plugged in my VGA monitor and started working with the command line menu (Windows OS). There I discovered something like 30 backups but could only see the first oldest 6 on screen. frustrated I didn't know how to scroll or see the last 2. I took a guess and entered 29 and pfsense was restored.

    I tried a few keyboard commands but couldn't get to the last backups in the list which scrolled through v fast. How do I stop the list scroll when using the restore from internal backup option? Thanks


  • Netgate Administrator

    The Scroll-Lock button should work for that on a directly attached keyboard/monitor.

    Hit ScrollLock then use the cursor up/down keys. Retro-tastic! 😉

    Steve



  • Thanks, I think I tried everything but I'll have another go. freeBSD and keyboards has given me a lot of grief. I started off using my UK PC keyboards, thought I'd picked the correct keyboard in the initial install dropdown but some keys were not correctly mapped. So I went and bought a USA keyboard and that was at the top of the list with pfsense 2.4.3, so I thought that would be fine. But I'm sure the scroll lock key still isn't working for me.

    The last time I got frustrated over this on a previous version of pfsense I tried to find a way of changing the keyboard after installation and never found an easy way other than diving into the operating system with command line editing and I didn't want to go there again.

    Not so smart, but it's actually easier to repeat installs from flash and try to get the keyboard right first. Now I have pfsense working I'm reluctant to go back.

    Whilst in this conundrum at the command line menu I thought I'd get back to a 'clean' install with manufacturer defaults and hoped that would erase anything about my previous VPN setups. I needed this because I just couldn't get rid of routes and references to my previous VPN provider. No luck at all since after a reboot from the CLI I still found left over traces and it didn't clean up pfsense? In the end I went for a fresh re-install from flash which clobbered the files or caches with left over traces. During that install I was curious about some data traffic when the LAN-WAN got established only to find that even after downloading the latest USB flash image, there's an update going on. You don't need that when you are setting up IP addresses and routes. In my case, I was setting up a fixed IP on my connected client but pfsense was updating which threw me until I worked out it can do that once a route is established, albeit without the VPN and working client interface.

    I am a noob and will fall into holes, but getting the right function from a keyboard during an install is pretty important as is having peace of mind there are no left over tracks - which I'm already used to with Windoze.


  • Netgate Administrator

    I feel your pain! I have spent waaay too long trying to type | with UK keyboards attached to the console. 😉

    I hardly ever use a direct attached console. Using serial console or SSH negates this issue.

    However I did test the scrolllock button using a UK keyboard and it worked fine.

    Steve