PcEngines APU4B4 install failures ** RESOLVED



  • Picked up a new PcEngines APU4B4, along with a mSata drive to attempt pF deployment and I'm beating my head on the desk trying to simply get an install completed.

    I've tried the 2.35 / 2.4.3 CE-Memstick-serial releases with different failures. I have attempted with different USB sticks / ports to rule out compatibility. Closest I have come is with an 8GB SD card with 2.3.5 image and kern.cam timeout delay set. I get boot up to picking R/I and then it dumps to single user. Other attempts with 2.4.x will not even progress that far without dumping install script out to a logon prompt that does not accept any documented logons.

    I attempted full install to the mSata drive while in another system. Lacking some skills in figuring out how to reconfigure the boot up to the proper port on the APU, since it was seen as a USB device and mapped as such on the other system.

    I have installed the latest bios for the device , 2.8.01 and devices appears to be healthy, booting into TinyCore with no issues.

    Anyone had any recent encounters trying to boot/install to an APU4?


  • Netgate Administrator

    Does it boot the 2.4.3 memstick serial installer successfully in all cases?

    Are you able to see any sort of error after the installer fails? At what point does it fail? What install options did you choose?

    Steve



  • Doesn't appear to complete boot process, I am able to get into loader pre-boot and set the kern.cam.delay and when after it loads the nics this is the last section of the kernel boot with 2.4.3:

    *Script /etc/rc.d/devd interrupted
    add host 127.0.0.1: gateway lo0 fib 0: route already in table
    add host ::1: gateway lo0 fib 0: route already in table
    add net fe80::: gateway ::1
    add net ff02::: gateway ::1
    add net ::ffff:0.0.0.0: gateway ::1
    add net ::0.0.0.0: gateway ::1
    Generating host.conf.
    eval: cannot create /etc/host.conf: Read-only file system
    eval: cannot create /etc/host.conf: Read-only file system
    eval: cannot create /etc/host.conf: Read-only file system
    Creating and/or trimming log files.
    Starting syslogd.
    Clearing /tmp (X related).
    Starting local daemons:/dev/md3: 8.0MB (16384 sectors) block size 32768, fragment size 4096
    using 4 cylinder groups of 2.03MB, 65 blks, 384 inodes.
    super-block backups (for fsck_ffs -b #) at:
    192, 4352, 8512, 1Script /etc/rc.d/local interrupted
    Updating motd: /etc/motd is not writable, update failed.
    Mounting late filesystems:.
    Configuring vt: blanktime.
    Starting cron.
    Starting background file system checks in 60 seconds.

    Wed Dec 6 08:14
    FreeBSD/amd64 (Amnesiac) (ttyu0)

    login:*

    After several attempts, this has been the consistent output with 2.4.3. With 2.3.5 I can get to the point of picking (I)nstall and the first dialog for picking screen font defaults and the script exits.

    At this point I'm trying to install from SD > mSata. USB install attempts with different media has not altered results.



  • Loading 2.3.5 nets these results:

    0_1531700696853_Screen Shot 07-15-18 at 07.23 PM.JPG

    Selecting install this is what I get next (no other load messages):

    0_1531700729391_Screen Shot 07-15-18 at 07.23 PM 001.JPG


  • Netgate Administrator

    Hmm. I haven't actually had a chance to try an install with v4.8.0.1 Coreboot. I only have an APU1 to test against also.

    Have you read through this? https://github.com/pcengines/apu2-documentation/blob/master/docs/pfSense-install-guide.md

    Steve



  • Yes I have ran through that doc, and I have flipped between several bios versions to see if I can't find a working combo.

    Stumbled across an article describing issues with the usb to serial cable using a prolific 2303 driver on Windows 10. I'm trying to put together a linux box with an actual serial port connected to it to get around that conversion and see if I have any better luck. It's a stretch - but I think I've tried every combo I can think of with no better results.



  • For all following - this has been resolved and I have now successfully installed 2.3.5 and cleanly upgraded to latest 2.4.1 via web console.

    Root of boot / install failures was using a Prolific 2303 driver with Win 10.

    Finally dug up a serial header to attach to desktop and bang! Booted right into installer and deployed to mSata drive on first attempt. For anyone that might run into similar issues, be very certain the serial connection being used is either direct or running under something other than Win10 on that particular serial-to-usb controller.