<Solved> Configuration after reboot



  • Sometimes after reboot pfSense start to launch configuration setup (use VLAN y/n, choose WAN interface, choose LAN interface)
    So i must assign WAN and LAN interfaces, set IP for LAN, login in web gui and choose configuration from backup history to manage it work again

    I've read somewhere that it happens if pfSense lose any interface during load and start configuration master
    Is there any way to avoid that?

    2.3.4-RELEASE (amd64)
    built on Wed May 03 15:13:29 CDT 2017
    FreeBSD 10.3-RELEASE-p19


  • Rebel Alliance Developer Netgate

    That definitely is not normal. Can you describe your setup in more detail? Specifically if you have any out-of-the-ordinary interfaces configured like USB Ethernet or a 4G/LTE type device that looks like an Ethernet interface.



  • Yes i have 4g usb modem ZTE MF823 as a backup
    Also this modem wont identify as ethernet interface until i run usbconfig -d 8.2 set_config 2
    So i added hw.usb.quirk.0="idVendor idProduct 0x19d2 0x1403 UQ_CFG_INDEX_2" in /boot/loader.conf


  • Rebel Alliance Developer Netgate

    That's probably why then, the interface isn't there at boot time, so there is a mismatch.

    Maybe add that usbconfig command (with the full path to usbconfig) as an earlyshellcmd entry with the shellcmd package.



  • @jimp thanks for suggession i will try that tomorrow
    Also i incorrectly explained the situation this occur after power loss or turn off, not the reboot


  • Rebel Alliance Developer Netgate

    It may take more time to reinitialize/switch after a cold boot. You might want to make a short script to initialize the modem which also performs a sleep for 10 seconds or so after issuing the mode switch command. Or maybe on a warm boot it keeps the mode. Either way it's safer to initialize it and wait a few moment and then let the boot proceed.



  • @jimp can i add <earlyshellcmd>sleep 30</earlyshellcmd> to xml file to pause boot process?
    or i should do it some other way


  • Rebel Alliance Developer Netgate

    Using the full path to the sleep command, yes, but if you make a shell script that does both it would be easier to keep track of the fact that the two commands are related. Either way should work, however. 30s is likely too long, but you'd have to test it to know for sure how long you need.



  • Managed to make this work for some reason i used <shellcmd> instead of <earlyshellcmd>