Error upgrading from 2.3.5_1 to 2.4.3



  • I am currently running 2.3.5_1 on Netgate SG-4860. I have been trying to upgrade to 2.4.3 and got the following error:

    >>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    >>> Locking package pkg... done.
    >>> Unlocking package pkg... done.
    >>> Downloading upgrade packages... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (162 candidates): .......... done
    Processing candidates (162 candidates): .......... done
    The following 178 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	openvpn: 2.4.4_1 [pfSense]
    	devcpu-data: 1.16 [pfSense]
    	pear-Crypt_CHAP: 1.5.0 [pfSense]
    	pear: 1.10.5_1 [pfSense]
    	pear-XML_RPC2: 1.1.3 [pfSense]
    	pear-HTTP_Request2: 2.3.0,1 [pfSense]
    	pear-Net_URL2: 2.2.1 [pfSense]
    	pear-Cache_Lite: 1.7.16,1 [pfSense]
    	pear-Net_IPv6: 1.3.0.b2_2 [pfSense]
    	pear-Net_Growl: 2.7.0 [pfSense]
    	pear-Auth_RADIUS: 1.1.0 [pfSense]
    	mobile-broadband-provider-info: 20170310 [pfSense]
    	pear-Mail: 1.4.1,1 [pfSense]
    	pear-Net_SMTP: 1.8.0 [pfSense]
    	pear-Net_Socket: 1.0.14 [pfSense]
    	py27-ply: 3.10_1 [pfSense]
    	py27-setuptools: 36.5.0 [pfSense]
    
    Installed packages to be UPGRADED:
    	webp: 0.6.0_4 -> 0.6.1 [pfSense]
    	unbound: 1.6.6 -> 1.6.8 [pfSense]
    	tiff: 4.0.8 -> 4.0.9_1 [pfSense]
    	strongswan: 5.6.0 -> 5.6.2_1 [pfSense]
    	ssh_tunnel_shell: 0.1 -> 0.1_1 [pfSense]
    	sqlite3: 3.20.1_1 -> 3.21.0_1 [pfSense]
    	snort: 2.9.9.0_3 -> 2.9.11.1_1 [pfSense]
    	smartmontools: 6.5_2 -> 6.6_1 [pfSense]
    	readline: 7.0.3 -> 7.0.3_1 [pfSense]
    	radvd: 1.9.1 -> 2.17_4 [pfSense]
    	qstats: 0.1_1 -> 0.2 [pfSense]
    	python27: 2.7.14 -> 2.7.14_1 [pfSense]
    	php56-zlib: 5.6.32 -> 5.6.34 [pfSense]
    	php56-xmlwriter: 5.6.32 -> 5.6.34 [pfSense]
    	php56-xmlreader: 5.6.32 -> 5.6.34 [pfSense]
    	php56-xml: 5.6.32 -> 5.6.34 [pfSense]
    	php56-tokenizer: 5.6.32 -> 5.6.34 [pfSense]
    	php56-sysvshm: 5.6.32 -> 5.6.34 [pfSense]
    	php56-sysvsem: 5.6.32 -> 5.6.34 [pfSense]
    	php56-sysvmsg: 5.6.32 -> 5.6.34 [pfSense]
    	php56-sqlite3: 5.6.32 -> 5.6.34 [pfSense]
    	php56-sockets: 5.6.32 -> 5.6.34 [pfSense]
    	php56-simplexml: 5.6.32 -> 5.6.34 [pfSense]
    	php56-shmop: 5.6.32 -> 5.6.34 [pfSense]
    	php56-session: 5.6.32 -> 5.6.34 [pfSense]
    	php56-readline: 5.6.32 -> 5.6.34 [pfSense]
    	php56-posix: 5.6.32 -> 5.6.34 [pfSense]
    	php56-pfSense-module: 0.13_1 -> 0.61 [pfSense]
    	php56-pdo_sqlite: 5.6.32 -> 5.6.34 [pfSense]
    	php56-pdo: 5.6.32 -> 5.6.34 [pfSense]
    	php56-pcntl: 5.6.32 -> 5.6.34 [pfSense]
    	php56-openssl: 5.6.32 -> 5.6.34 [pfSense]
    	php56-opcache: 5.6.32 -> 5.6.34 [pfSense]
    	php56-mcrypt: 5.6.32 -> 5.6.34 [pfSense]
    	php56-mbstring: 5.6.32 -> 5.6.34 [pfSense]
    	php56-ldap: 5.6.32 -> 5.6.34 [pfSense]
    	php56-json: 5.6.32 -> 5.6.34 [pfSense]
    	php56-hash: 5.6.32 -> 5.6.34 [pfSense]
    	php56-gettext: 5.6.32 -> 5.6.34 [pfSense]
    	php56-filter: 5.6.32 -> 5.6.34 [pfSense]
    	php56-dom: 5.6.32 -> 5.6.34 [pfSense]
    	php56-curl: 5.6.32 -> 5.6.34 [pfSense]
    	php56-ctype: 5.6.32 -> 5.6.34 [pfSense]
    	php56-bz2: 5.6.32 -> 5.6.34 [pfSense]
    	php56-bcmath: 5.6.32 -> 5.6.34 [pfSense]
    	php56: 5.6.32 -> 5.6.34 [pfSense]
    	pfSense-rc: 2.3.5_1 -> 2.4.3 [pfSense-core]
    	pfSense-pkg-snort: 3.2.9.5_4 -> 3.2.9.6_1 [pfSense]
    	pfSense-pkg-ipsec-profile-wizard: 0.10 -> 0.11 [pfSense]
    	pfSense-pkg-Status_Traffic_Totals: 1.2.2 -> 1.2.4 [pfSense]
    	pfSense-pkg-RRD_Summary: 1.3.2_2 -> 2.0 [pfSense]
    	pfSense-pkg-AutoConfigBackup: 1.50 -> 1.51 [pfSense]
    	pfSense-kernel-pfSense: 2.3.5_1 -> 2.4.3 [pfSense-core]
    	pfSense-default-config-serial: 2.3.5_1 -> 2.4.3 [pfSense-core]
    	pfSense-base: 2.3.5_1 -> 2.4.3 [pfSense-core]
    	pfSense-Status_Monitoring: 1.6.5 -> 1.7.6 [pfSense]
    	pfSense: 2.3.5_1 -> 2.4.3 [pfSense]
    	p7zip: 16.02 -> 16.02_1 [pfSense]
    	oniguruma6: 6.4.0 -> 6.6.1 [pfSense]
    	ntp: 4.2.8p10_2 -> 4.2.8p11 [pfSense]
    	nginx: 1.12.1_2,2 -> 1.12.2_3,2 [pfSense]
    	nettle: 3.3 -> 3.4 [pfSense]
    	mysql56-client: 5.6.37_1 -> 5.6.39 [pfSense]
    	mpd5: 5.8_2 -> 5.8_3 [pfSense]
    	luajit: 2.0.5 -> 2.1.0.b3 [pfSense]
    	libzmq4: 4.2.2 -> 4.2.2_1 [pfSense]
    	libunistring: 0.9.7 -> 0.9.8 [pfSense]
    	libnghttp2: 1.26.0 -> 1.29.0 [pfSense]
    	libffi: 3.2.1_1 -> 3.2.1_2 [pfSense]
    	libevent: 2.1.8 -> 2.1.8_1 [pfSense]
    	json-c: 0.12.1 -> 0.13 [pfSense]
    	jpeg-turbo: 1.5.2 -> 1.5.3 [pfSense]
    	isc-dhcp43-server: 4.3.6_1 -> 4.3.6P1 [pfSense]
    	isc-dhcp43-relay: 4.3.6 -> 4.3.6P1 [pfSense]
    	isc-dhcp43-client: 4.3.6 -> 4.3.6P1 [pfSense]
    	indexinfo: 0.2.6 -> 0.3.1 [pfSense]
    	igmpproxy: 0.1_3,1 -> 0.1_5,1 [pfSense]
    	idnkit: 1.0_6 -> 1.0_7 [pfSense]
    	glib: 2.50.2_6,1 -> 2.50.3_1,1 [pfSense]
    	freetype2: 2.8 -> 2.8_1 [pfSense]
    	filterlog: 0.1_4 -> 0.1_5 [pfSense]
    	filterdns: 1.0_9 -> 1.0_16 [pfSense]
    	expat: 2.2.1 -> 2.2.5 [pfSense]
    	dpinger: 2.0 -> 3.0 [pfSense]
    	daq: 2.0.6_1 -> 2.2.2 [pfSense]
    	curl: 7.57.0 -> 7.58.0 [pfSense]
    	check_reload_status: 0.0.7 -> 0.0.8 [pfSense]
    	ca_root_nss: 3.32.1 -> 3.36 [pfSense]
    	bind-tools: 9.11.2 -> 9.11.2P1 [pfSense]
    	bandwidthd: 2.0.1_11 -> 2.0.1_12 [pfSense]
    
    Installed packages to be REINSTALLED:
    	zip-3.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	xinetd-2.3.15_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	wrapalixresetbutton-0.0.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	wpa_supplicant-2.6_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	wol-0.7.1_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	vstr-1.0.15_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	voucher-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	vnstat-1.15 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	uclcmd-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	sshlockout_pf-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	scponly-4.8.20110526_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	rrdtool-1.7.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	relayd-5.5.20140810_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	rate-0.9_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	python2-2_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	png-1.6.34 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	php-xdebug-2.5.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	php-suhosin-0.9.38_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	pftop-0.7_8 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	pfSense-pkg-openvpn-client-export-1.4.14 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	pfSense-pkg-aws-wizard-0.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	perl5-5.24.3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	pecl-zmq-1.1.3_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	pecl-rrd1-1.1.3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	pecl-radius-1.4.0.b1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	pcre-8.40_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	openvpn-client-export-2.4.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	openldap-client-2.4.45 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	norm-1.5r6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	miniupnpd-1.9.20160113,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	minicron-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	lzo2-2.10_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	links-2.13,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libxml2-2.9.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libucl-0.8.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libpcap-1.8.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libmcrypt-2.5.8_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	liblz4-1.8.0,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libltdl-2.4.6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libidn2-2.0.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libiconv-1.14_11 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libgd-2.2.4_1,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libedit-3.1.20170329_2,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libdnet-1.12_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	libdaemon-0.14_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	ldns-1.7.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	jbigkit-2.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	ipmitool-1.8.18_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	hostapd-2.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	gmp-6.1.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	giflib-5.1.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	gettext-runtime-0.19.8.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	expiretable-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	dnsmasq-2.78,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	dmidecode-3.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	dhcpleases6-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	dhcpleases-0.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	dhcp6-20080615.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	cpustats-0.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	cpdup-1.18 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	clog-1.0.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	choparp-20150613 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	bwi-firmware-kmod-3.130.20 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	bsnmp-ucd-0.4.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	bsnmp-regex-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	broccoli-1.97,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	beep-1.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	barnyard2-1.13_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	aws-sdk-php-3.29.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	ataidle-2.7.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    	GeoIP-1.6.11 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    
    Number of packages to be installed: 17
    Number of packages to be upgraded: 90
    Number of packages to be reinstalled: 71
    
    The process will require 32 MiB more space.
    126 MiB to be downloaded.
    [1/178] Fetching zip-3.0_1.txz: .......... done
    pkg-static: cached package zip-3.0_1: size mismatch, fetching from remote
    [2/178] Fetching zip-3.0_1.txz: .......... done
    pkg-static: cached package zip-3.0_1: size mismatch, cannot continue
    Failed
    

    I am performing the upgrade from the GUI and have not tried it from the command line.

    Does anyone have any suggestions of a fix?

    Thanks



  • Found out what was causing the error. I had an outdated package catalogue.

    To fix the error I used the following commands from the shell:

    pkg-static clean
    pkg-static update -f

    The force is necessary for the update, since the pkg manager thinks it is up-to-date.