Interrupt storm on irq11

  • I have a Foxconn motherboard with a Phoenix Award BIOS on it. I've been running pfSense on the rig for just under a year now but here's my newest, or latest issue…

    I have a SATA hard drive and a SATA DVD drive attached to the motherboard. I've d/l'ed and burned 1.2.2 stable to a CD-RW. I went in today to try and install the latest stable release of 1.2.2 but during boot from the CD i get the following message: "interrupt storm on irq11..."

    I've read quite a few posts from here and elsewhere about this and decided to tinker with BIOS settings. I messed with AHCI mode, SATA mode, disabled...doesn't matter they all give that error! I usually try to launch with the default mode from the CD but in the past I've had to use "safe mode" just to get anywhere with the installs. Anyway, it's as though the progress stalls around right around the time it finds "ad0" or something like that and then it gets to the DVD drive, displays it and then BAM! "interrupt storm on irq11..."

    I have disabled every conceivable thing in my BIOS...and I mean everything, including USB. I used the /status.php page and searched for IRQ 11 and saw UHCI next to it so I figured it must be the USB...well it wasn't, unfortunately. So then when I'm rebooting the machine, if I have it in SATA mode, IRQ 11 is my IDE Controller and it shares with my SMBus Controller too. If I change it to AHCI, then IRQ 11 simply becomes Mass Storage Controller. Is this a FreeBSD issue with regard to SATA components?

    I'm just lost at this point. I'm out of ideas and could use any that you all might have.

  • Have the same problem.

    My system is a Thinkpad A22e wiwth pfSense 1.2.2. By changing the interrupts in bios I have narrowed my problem down to..

    cbb1 OR ed1++



    Here are some outputs with the problem interrupts 9 and 15.
    pciconf -l -v

    vmstat -i

    Seems to be a FreeBSD issue and not a pfsense issue.

  • Yeah it's a FreeBSD issue. I suggest trying 1.2.3 as it's based on a newer FreeBSD release.

Log in to reply