no connection from Pfsense server LAN to router's WAN



  • I have 2 WAN and 1 LAN. When LAN connected directly to PC or in LAN port of router, internet works. But when connected to router's WAN port with the same configuration as in PC (same IP, gateway and dns ), no internet. Tracert ends in router's lan address.


  • Rebel Alliance Global Moderator

    Huh? Why would you be connected lan into your wan.. At a loss to what your issue is..

    Are you saying this wan works when using a pc to test it... But when using the same IP settings as the PC that worked on your now wan2 on pfsense.. It doesn't work?

    What provides this wan2? Is it a cable modem? Quite often when mac address of device connected to cable modem changes you will need to power cycle the cable modem to work with the new different mac.

    How are you telling your clients to use this new wan? Can pfsense ping the gateway of this new wan network?



  • The problem I think is there is no rule for LAN in NAT outbound. But I failed to do so.0_1532965596137_Capture.PNG



  • 2 WAN AND 1 LAN Interface in pfsense. This LAN (192.168.69.1) when connected to PC it works (192.168.69.14, gateway 192.168.69.1, dns 1.1.1.1). This LAN also works perfectly when connected to router via LAN port.

    But LAN when connected to WAN it doesn't work even tried with the same setting (192.168.69.14, gateway 192.168.69.1, dns 1.1.1.1). Router's LAN IP is 192.168.99.29
    This is the tracert result 0_1532965948270_Capture1.PNG


  • Rebel Alliance Global Moderator

    Your outbound nat wouldn't be on your LAN interface anyway.. But yeah your most likely going to have to outbound nat on 2nd wan interface But seem this 2nd wan of your yours is also rfc1918..

    Pfsense will auto know how to nat when you create an interface with a gateway it auto becomes a "wan" but your going to have to tell pfsense when and how to use this new wan, and which clients to send using this wan.. Say with policy routing.

    https://www.netgate.com/docs/pfsense/routing/multi-wan.html



  • I think I did not describe my situation clearly.
    I have 2 WAN and 1LAN interface in pfsense server. This LAN interface from server is what I am using to create another network via router. Now doing so it does not work (shows in router's page 'WAN cable not connected properly').
    However, when this LAN interface connected in bridge mode in router or in PC, it works perfectly.

    Sorry if it is exactly what you understood before.



  • I cannot even ping gateway from router which is ip of LAN interface