[Solved] Stuck on "Configuring WAN interface..." during install 2.4.3



  • I have just bought new hardware for my pfSense and I started out by making a fresh install today (pfSense-CE-memstick-2.4.3-RELEASE-amd64.img) on the new machine. All good so far but when I tried to boot with WAN-cable connected it hangs on "Configuring WAN interface..." for 30+ minutes. How can I pass it? Please see attached screenshot. Same thing if I boot the machine without WAN-cable and then after it has fully booted up and I connect the WAN-cable everything freezes. The only thing I can think of is that there is something wrong with the DCHP client in this version?

    0_1533166754532_IMG_20180801_230543.jpg

    Any suggestions are appreciated
    Sincerely,
    ~TrueType

    EDIT: Solved! My solution below if anyone else needs it sometime.



  • I get a delay on that step also when the upstream doesn't provide DHCP.
    I'd suggest booting with the cable unplugged and setting a static IP, then plugging it back in and trying again.


  • Rebel Alliance Developer Netgate

    If it's new hardware, perhaps when you restored the configuration you did not get the cables plugged into the correct network interfaces. If you have WAN and LAN swapped, for example, your WAN interface would fail to pull a DHCP address.



  • @jimp I tried reassign and try again but no success. I tried reseting to factory with no succes and I also tried reinstalling with 2.3.5 with standard settings and same problem. :'(



  • @edooze booted up with no wan and plugged in wan right after this step in loading. Waited to complete boot then set a static ip on wan, apply, then dhcp and apply but then it just keeps loading (hangs)



  • I found the cause of the problem! My network cable (in the wall) which is leading to the ISP switch is only Cat 5 and my hardware / pfSense could not measure it was only "100baseTX <full-duplex>" so after setting this manually it went pass the configuring WAN step. Now I am installing updates tho! :)