"Invalid partition table!" error while booting from USB media to install



  • Hi all,

    I'm on the verge of reinstalling my pfSense box because I have some weird issues and can't find the time to sort them out.
    So I've tried to create a bootable USB drive, but for some reason it keeps getting up with "Invalid partition table!" error at boot.
    It doesn't matter if I create it with Win32Img, dd or etcher. I've tried different USB drives to rule a hardware error out.
    I read something about bios updates, but for this particular piece of hardware there are no bios updates available.
    Bios is in legacy boot mode, secure boot disabled.
    For instance, a Kali Linux or Windows boots fine.

    I've tried the latest, 2.4.3 and all the way down to 2.4.0.
    Anyone a clue? Thanks in advance.



  • Use UEFI mode if possible, the legacy emulation might have bugs on your system that make it spit out the errors when it detects a slightly unusual partition table on the USB drive. The pfSense memstick images use GPT partitioning and there are quite a few BIOSes that choke on perfectly standard partition tables that just happen to be hybrid MBR/GPT.



  • Thanks for the quick reply @kpa
    The USB boots with UEFI enable on my test laptop, so that seems to be the main issue.
    I hope my (very old) pfsense box has UEFI to boot from...

    Cheers.