Cannot disable "DNS resolver"



  • I would like to disable "DNS resolver" and run "DNS forwarder"
    But when I try to disable it, or make any change to it, I got the following errors
    The following input errors were detected:

    The generated config file cannot be parsed by unbound. Please correct the following errors:
    /var/unbound/test/unbound_server.pem: No such file or directory
    [1533246902] unbound-checkconf[33259:0] fatal error: server-cert-file: "/var/unbound/test/unbound_server.pem" does not exist

    PS. we cannot resolve any name from a client either when using the box as DNS.
    But using this command will return and answer
    nslookup cnn.com 8.8.8.8

    running
    2.4.3-RELEASE-p1 (amd64)
    built on Thu May 10 15:02:52 CDT 2018
    FreeBSD 11.1-RELEASE-p10

    Thank you


  • Moderator

    @bbarzideh

    Try to disable DNSSEC and/or try a reboot of the box.



  • So it seems the 30G drive is at %100.
    What is the recommended Disk space?



  • pfSense only need a few gigs. A better question is how much space do you need? Based on your usage, I assume you're running a proxy(squid) and the proxy's cache is eating up all the HD you can throw at it. Trying to cache the entire internet?