Unable to send Notifications on Pfsense 2.4.3_1



  • Hi, I'm new to Pfsense and was trying to setup notifications from SMTP, mostly to know when one of my to gateways go downs

    I've made all configurations to send through my gmail account and when I test it, the it shows the result "SMTP testing e-mail successfully sent". But no message is actually sent.

    Output roles are allowing the IPs and Ports.

    I noticed two weird things:

    1. The "SMTP testing e-mail successfully sent" message shows almost immediately, really, it is too fast to actually send a message

    2. When I do a tcpdump there is no package sent to any interface to the SMTP IP.

    The worst thing is that I don't even know that logs to search for more info and solve this.

    Tried to google for someone experiencing the same problem, but got nothing.

    Regards,
    Leandro R. De Bom



  • @debom If your settings are different, try the settings below. In the Notification E-Mail auth password, enter your gmail password. The next step is VERY IMPORTANT. You MUST scroll all the way to the bottom of the page and click the Save button. Then click on the Test SMTP Settings button. The settings entered do not get used unless they are first saved.

    If it still does not work, you might have to go into your Google account security settings and allow less secure applications. I don't think this is necessary though. If you do allow less secure apps and it still doesn't help, don't forget to switch that setting back.
    https://support.google.com/cloudidentity/answer/6260879?hl=en

    0_1534436528892_e57d5a38-7a96-4e94-a047-081717253282-image.png