LAGG on Switched Ports on SG-3100 - Flapping



  • Hey All,

    I'm struggling trying to get Link Aggregation working on the SG-3100 internal switchports.

    I found one other post (Seemingly the only other post) regarding this which suggested you can do this via CLI using etherswitchcfg.

    I'd like to do this with a pair of Cisco C3750Gs but I can't get it working. The LAGG is created and displayed under LAGGs but my switches complain of PfSense flapping between the two ports.

    I configured it as a Static LAGG on the switch stack but pfsense just grinds to a halt everytime I do it as if it's causing some kind of network loop.

    I suspect this may be to do with the loadbalancing method used by the netgate appliance, but I'm not sure how I could check this? I suppose if the Netgate switch has the same MAC across the two ports and is configured for active/active, my Cisco switches would be constantly relearning the MAC addresses and contribute to port flapping.

    Any ideas?

    My switch config is below;

    !
    interface po10
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Gi1/0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 10 mode on
    !
    interface Gi2/0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 10 mode on
    !
    

  • Netgate Administrator

    The only lagg mode available (currently) when you do that is loadbalance so it is expected traffic will use both ports.

    Your switch will need to be configured to expect that.

    It's possible we may be able to add other lagg modes in the future but there is no schedule for that.

    Steve



  • This post is deleted!


  • Hi @stephenw10

    Thanks for the quick reply.

    I figured it may well do this, hopefully LACP or other methods will be introduced in the future!

    In the mean time.... do you have any suggestions on the best way to configure this? If I take out the port channel on my switch stack and leave them as two individual trunk ports, I suspect this may sort it.. But I guess that depends on if the MAC seen from the Netgate appliance is static on each interface and doesn't flip between them.

    ~Mat


  • Netgate Administrator

    I expect the MAC to be the same on both channels for a lagg configuration so your switch will need to be configured for lagg to allow for that.
    In this situation you are in effect connecting a switch to a switch so the MAC address you will see will likely be from some upstream device anyway, probably the mvneta1 internal interface. It could appear on either port though with the load balance configuration.

    "Port Channel" appears at first glance to be the correct way to do that but I'm not sufficiently familiar with Cisco nomenclature to be of much further assistance there.

    Steve



  • Thanks Steve,

    I do indeed see the same MAC on each port, and this is the upstream mvneta1. However, what's odd is I re-attempted this but using ports 3,4 instead of 1,2. 1,2 are currently active for everything else, so I wanted to avoid any more disruption!

    Anyway.. this time I didn't get any MAC address flapping errors on the switch but if I pulled out cable A everything continued working. If I swapped them and pulled out B everything would drop. I left it for a good 10-15 minutes while I went and got a brew and it never moved over to the other interface, despite the port channel being up on the switch.

    I'll ask a couple of our network engineers and see if they can figure it out.