PFSense with unraid docker Nowplaying



  • So I have an unraid docker called Nowshowing, this docker creates an email page that allows me to see all the new movies (don't really need this feature) but it also emails all the people who use my PLEX server and tells them whats new that has been downloaded over the last week. Ever since I made the move to PFSense this docker doesn't work anylonger. Has anyone figured out the right settings in PFSense to let this docker work?


  • Rebel Alliance Global Moderator

    I run the same docker (https://hub.docker.com/r/ninthwalker/nowshowing/), I run it on synology nas but there is nothing special to do in pfsense for that to work. your saying it can not email.. Or users can not access the website remotely? If you want them to access the website remotely you would have to use port forward, and you would have to make sure they hit your public IP or fqdn that resolves to your public vs your private

    0_1533723178254_nowshowing.png

    That is the website I do not have that open to users... And here is email they get everyday

    0_1533723468614_email.png

    Unless your blocking the docker from internet access or locking down your pfsense lan rules from the default any any the email should work, and you would have to setup port forward for the website report to be access from public internet.



  • No I’m not talking about accessing the webpage, I’m talking about the actual email the nowshowing sends to the users. But if your saying there isn’t any special settings then the problem must be with either the new version of nowshowing (version2) or with Yahoo’s SMTP, or a combination of the two.


  • Rebel Alliance Global Moderator

    yeah unless you blocked the port your using to send the email on purpose.. Guess you are just using the yahoo dropdown in the nowshowing smtp settings.

    Are you running anything like snort that might be blocking it? You would run a sniff on pfsense when you do a test email report.

    Are you having any issues using yahoo email from another client? Not the web interface but the smtp like say outlook client?



  • That I know of I’m not blocking the port (I’ve forwarded the port to the web GUI and can access it outside my network). They only things I have running on pfsense is pfblockerNG. And yes I did just use the drop down to select the yahoo account. So I’m not sure where the problem is occurring. I’ve check the reports of pfblockerNG and it’s not showing that it’s blocking anything from nowshowing’s IP address. BTW thanks for assisting. Is there anything that I can provide that might help with trouble shooting this? (ie. logs)


  • Rebel Alliance Global Moderator

    Turn off pfblocker.. Does it work? I will have to look to see if logs are available on the docker when it tries and emails. Guess I could try moving it to my yahoo account vs gmail currently using. I do believe I had to enable it in gmail since I have 2fa gmail setup, etc.

    you do not need the port forward, and would not recommend you open that up to the public unless you have some real need for that.

    The default lan rules are any any.. So unless you added rules above that no there is nothing on the lan rules that could be blocking it. Did you create any floating rules?

    Pfblocker would be my guess.. Should be simple enough to disable and test.



  • I’ve tried disabling pfblockerNG and that didn’t make any changes, unfortunately. I do not have any floating rules either. I could try search through pfblockerNG log files to see if I can find anything in there that might indicate that it’s blocking it somehow, but I’m not certain that would show me anything since it still doesn’t work even after disabling PFblocker


  • Rebel Alliance Global Moderator

    let me see if I can still login into my yahoo account.. Haven't touch it long time ;) if so will try changing my nowshowing to use that account and see what happens.

    Sure you just didn't typo the username/password?



  • LOL, that’s the first thing I checked. I wanted to avoid bothering others for help to only find I typed the email password wrong. I could try changing it to my gmail account to see if that works


  • Rebel Alliance Global Moderator

    Ok I tried setting this up with my yahoo and getting this in the log about authentication failure. Are you seeing the same thing after trying to send a test email report?

    0_1533744112960_emaillogs.png

    I know the password is correct since I logged into my yahoo account. But it could be something with yahoo needing specific auth methods or allowing.. like gmail does with applications.

    Give me a few min.. But I know for fact that gmail does work, since that was what I was using.. Now that switched will prob have to setup app password again. Give me a few minutes to troubleshoot the yahoo thing.



  • So new issue...none of those buttons work (now showing logs) I can grab them from the app data folder but the button itself doesn’t work!
    I get this in the app data:
    I, [2018-08-08T00:35:51.332451 #1850] INFO -- : Script complete. Ran in 82.942580012 seconds
    I, [2018-08-08T00:44:08.911692 #2402] INFO -- : SMTP mailing failed!
    execution expired["/usr/lib/ruby/2.3.0/net/smtp.rb:542:in initialize'", "/usr/lib/ruby/2.3.0/net/smtp.rb:542:inopen'", "/usr/lib/ruby/2.3.0/net/smtp.rb:542:in tcp_socket'", "/usr/lib/ruby/2.3.0/net/smtp.rb:552:inblock in do_start'", "/usr/lib/ruby/2.3.0/timeout.rb:101:in timeout'", "/usr/lib/ruby/2.3.0/net/smtp.rb:551:indo_start'", "/usr/lib/ruby/2.3.0/net/smtp.rb:521:in start'", "/usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/network/delivery_methods/smtp.rb:112:indeliver!'", "/usr/lib/ruby/gems/2.3.0/gems/mail-2.6.3/lib/mail/message.rb:252:in deliver!'", "/var/lib/nowshowing/mailAnnouncement.rb:100:insendMail'", "/usr/local/sbin/announcementreport:87:in main'", "/usr/local/sbin/announcementreport:91:in<main>'"]
    I, [2018-08-08T00:44:08.911929 #2402] INFO -- : Announcement Email Sent.


  • Rebel Alliance Global Moderator

    Yeah seems to be failing... I would suggest you open ticket with nowshowing guy to get some help.. This is not a pfsense issue.. I see this in the logs.

    E, [2018-08-08T11:13:52.259933 #11208] ERROR -- : Something failed. If you are seeing this, please turn on debugging and open an issue.

    What I can say is gmail works - if you have gmail just use that.

    Well seems you got a problem with your setup.. I would get with them - they do have special unraid instructions. I am running it on synology so are setups are different. But I can not get yahoo to work either.


  • Rebel Alliance Global Moderator

    I take that back - they did work.. Just slow, and sent to my gmail account ;)

    0_1533745741732_didwork.png

    Now I did turn this on in yahoo..

    0_1533745760259_yahooemail.png



  • Yeah, I posted a thing for him on lime-tech about it, I just haven’t gotten an answer yet. I’m sure he is busy. Thank you for all your help and time!