failed upgrade to 2.4.3_1, now DHCP server broken



  • Hi, I upgraded from 2.3.2_1 to 2.3.5_2 which worked without any issues. I then tried to upgrade to 2.4.3_1 which the console shows as being successful but the system never reboots to complete the upgrade. I forced a reboot and the system always boots up as 2.3.5_2. Since trying this upgrade the DHCP server stops functioning after a random number of hours. Rebooting the system temporarily resolves the issue. Should I try to reload the config file, manually load 2.4.3_1 and import the config, other options? Thanks



  • Hi,

    if pfSense proposes 2.4.3_1, I presume you have a AMD64 compatible processor type, right ?

    An upgrade from 2.3.5_2 to 2.4.3_1 includes a reboot, and should be executed during the upgrade. If it didn't, rebooting yourself is a good thing and should bring you to 2.4.3_1 - it didn't so : If you have 5 minutes, make a copy (backup) of your config, and reinstall 2.4.3_1. This will take care of things 100 % sure.



  • @Gertjan, Thanks for responding so quickly. The system is an HP DL360 G6 - Intel Xenon L5520 which I think should be compatible. Just to be clear, your suggestion is to load 2.4.3_1 via USB or DVD then import my 2.3.5_2 config, correct? Any issues with an older config being imported into the latest version? Thanks



  • pfSense would propose you a 2.4.x version (exists only for 64 birs processors or type AMD64) if your processor is AMD64 compatible.

    Install pfSense as you did before, because I'm pretty sure your "HP DL360 G6" wasn't preloaded with pfSense in the past ;)

    You might also do a fresh install using 2.3.5_2 (the AMD64 version) from here
    0_1534079458036_c6c522af-00c9-441c-9a2b-9b937be3d067-image.png
    == https://www.pfsense.org/download/

    and then, after enabling the minimum = WAN interface only, upgrading immidiatly, using the upgrade function, to 2.4.2_1, or installing 2.4.2_1 right away.
    Import your "2.3.2_2" config into 2.4.2_1 will do just fine.

    Edit : stupid me.
    Consider your upgrade system "dead".
    The latest version isn't 2.4.2_1 - that was ages ago.
    It should say : 2.4.3 for several month now.
    0_1534080019451_ac07b20e-0519-4c6f-a5f9-ddacd2cc726d-image.png

    If your pfSense insist on proposing you 2.4.2_1 as the next available version then that is the version that is cached locally. Since then, way in the past, your pfSense can't reach the update servers any more. This might be explained by a DNS issue on your side, like pfSense itself can connect to the net anymore - this happens, people really manage to cut of pfSense from the net - be carefull when re using your saved config, it will contain a "wrong DNS setup".
    And before you ask, the update server of pfSense are doing well ^^

    So re install - for sure.



  • The update sees version 2.4.3_1. When I choose confirm to install, the process runs, states that the upgrade was complete, says rebooting in 10 seconds. At this point it never reboots. Forcing the reboot the system comes back up as 2.3.5_2. I will try a fresh install of 2.4.3_1 and import the config. Would you recommend using the config from 2.3.2_1 or 2.3.5_2? Do you think the DHCP issue is related to an unstable system due to the failed upgrade or the 2.3.5_2 config? I don't want to reintroduce issues by loading a bad config. Thanks



  • You probably don't need the config file.
    Setting up WAN (mandatory) and changing DHCP (why changing ? the default values will do just fine) is all it takes to make it work.

    Do not change any of the DNS settings - if you want to have a system that works, the default settings are doing a great job.

    Most packages, if you use any, have straight forward settings, easy to reproduce.



  • I definitely need to the config file. I have five VLAN interfaces with 10 - 30 firewall rules in each VLAN. I also have RADIUS running for network authentication with 30-40 MAC addresses defined. Unfortunately I don't have time to start from scratch. Worst case scenario I reinstall 2.3.2_1 and import my good 2.3.2_1 config. Where can I find the mem-stick download for 2.3.3?


  • Netgate Administrator

    You should definitely be running 2.4.3 on that hardware. Either of those earlier config files should import there without issue.

    Steve



  • @fwadmin4tvcc said in failed upgrade to 2.4.3_1, now DHCP server broken:

    2.3.3

    An old version ?
    Pointless to use already known bugs that were resolved.



  • Fresh install of 2.4.3, upgrade to p1, then imported the config from 2.3.2. Everything appears to be working except RADIUS which I need to reinstall since the package has been upgraded to version 3. Thanks for everyone's help.



  • Correct. radius 2 was declared dead some time ago, and shouldn't be used anymore anyway.
    FreeRadius 3 has some new, mandatory settings.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy