DNS Resolver crashing on fresh factory reset install



  • **** SEE UPDATE AT BOTTOM OF POST ***

    Hello,

    After receiving my PfSense SG-4860 unit back from repair, I spent the WE reinstalling it in my network.
    The unit is on the latest version (2.4.3-p1) and has been factory reset.
    So I started the install from scratch.

    I am not sure if, somewhere, I made a change that results in this whole issue, but whether I use the DNS resolver or the DNS Forwarder (I tried with both, not at the same time), the services will stop all the time. As a matter of fact they pretty much stay off. When on, it's for a few seconds at the most.

    I can hardly connect to any webpage. When it works, for a few seconds all is good. Otherwise (most of the time) most pages just time out.
    I've literally spent the WE trying to troubleshoot the issue and trying to get things to work.

    My install is still fairly vanilla:

    • I created several interfaces and VLANs
    • I set up the FreeRadius server to assign users to the VLANs
    • My DNS server (General setup) is currently 1.1.1.1
    • Pfsense acts as the DHCP server for my network and all my devices have static IPs
    • My firewall rules are 'allow to any' on all interfaces
    • I did not install any package other than FreeRadius

    While troubleshooting and looking at the logs I also decided to deactivate the DHCPv6 server (but that doesn't help either)

    I attached the screenshots of my settings and a few logs.

    Does anyone know what I might have done wrong?
    I really don't want to reset the whole system and start from scratch.

    PS: Just a quick addition: Every couple of hours, for no apparent reason, the DHCP Service goes down again as well. After random periods of time (30 mins, 1H, etc), it turns on again by itself.

    Any help greatly appreciated :)

    0_1534171190196_1.png
    0_1534171203428_2.png
    0_1534171213693_3.png
    0_1534171224694_4.png
    0_1534171235578_5.png
    0_1534171246371_6.png
    0_1534171258442_7.png

    (****** UPATE AUGUST 14 ******)

    So I decided to factory reset my unit and start from scratch:

    Did the reset and went through the configuration wizard.
    Did nothing special in there other than setting Cloudflare as DNS.
    Finished the wizard and... right away the DNS Resolver starts and stops again.
    I also get this error message in the top notification bar now:

    Filter Reload
    
     There were error(s) loading the rules: /tmp/rules.debug:18: file "/etc/bogons" contains bad data - The line in question reads [18]: table <bogons> persist file "/etc/bogons"
    

    So that error appears on a totally fresh install without me going into any tab yet :/

    Line 18 in the said file reads:

    table <bogons> persist file "/etc/bogons"
    

    and when I navigate to that file and open it, it just lists over 3000 IP addresses.

    So not really sure what I need to do from here on!
    Is a factory reset not a full reset? Are these possible left overs from a previous install?

    I am really at a loss here



  • Well, for those who might run into something similar, the solution in the end was to deactivate everything IPv6 on the interfaces and in DHCPv6 server.



  • The problem is the bogonsv6 list got too big, so you had to manually adjust the Firewall Maximum Table Entries.

    This was solved a few months ago.

    https://redmine.pfsense.org/issues/8417


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy