IGMPProxy is old - is it getting updated to the latest FreeBSD supported build?



  • Hi,
    According to pkg info we are currently running an old, no longer maintained version of igmpproxy:-

    pkg info igmpproxy
    igmpproxy-0.1_5,1
    Name           : igmpproxy
    Version        : **0.1_5,1**
    Installed on   : Tue Mar 27 00:13:03 2018 BST
    Origin         : net/igmpproxy
    Architecture   : FreeBSD:11:amd64
    Prefix         : /usr/local
    Categories     : net
    Licenses       :
    Maintainer     : melifaro@ipfw.ru
    WWW            : **http://igmpproxy.sourceforge.net/**
    Comment        : Multicast forwarding IGMP proxy
    Annotations    :
           repo_type      : binary
           repository     : pfSense
    Flat size      : 36.1KiB
    Description    :
    igmpproxy is a simple multicast routing daemon based on mrouted. It uses IGMP
    forwarding to dynamically route multicast traffic.
    Reqiures multicast forwarding enabled
    
    WWW: http://igmpproxy.sourceforge.net/
    

    Note that igmpproxy is currently at version 0.2.1,1 according to

    https://www.freebsd.org/cgi/ports.cgi?query=igmpproxy&stype=all

    and is no longer a sourceforge project and has been moved over to github where development continues.

    Will 2.4 bring this version? Can we manually upgrade that package?