Failover / Gateway Groups - many issues!!



  • Hi all,

    Having issues with gateway group failover. We have our main connection, which is Fixed-Wireless NBN, and our secondary connection which is 4G, running from the ethernet port of a Netgear Nighthawk M1 MR1100.

    It should switch over to using the 4G any time where there is either packet loss or high latency. It’s not doing that, it just stops working altogether.

    When the main connection goes down, it doesn’t totally cut off the ethernet port, so pfSense still thinks it’s “up”. But the interface has no IP address, and of course there would be 100% packet loss, so I’m not sure why it’s not failing over to 4G.

    Also, even if it does manage to failover correctly, or I walk upstairs and unplug the main connection ethernet port, all the devices in our office need to be either restarted or have their wifi disabled and then re-enabled. Why is this necessary?

    And today pfSense has stopped attempting to use the 4G altogether…so now it’s time for a reboot. Yep, it came back online after the reboot. Any ideas why this would be happening?

    I’ve attached some images of configuration. WAN is the main connection (Fixed-Wireless NBN) and WWAN is the 4G connection. I have connected directly to the Netgear M1 and it works fine, so there’s no issue with that device.

    0_1534290326967_Screenshot 2018-08-15 09.12.11.png

    0_1534290359643_Screenshot 2018-08-15 09.23.17.png

    0_1534290374037_Screenshot 2018-08-15 09.23.24.png

    0_1534290383799_Screenshot 2018-08-15 09.24.08.png



  • anyone?


  • Rebel Alliance Developer Netgate

    Maybe this: https://redmine.pfsense.org/issues/8586

    On the current release, the gateway trigger levels don't work, only the Member Down choice works.



  • But would "member down" work if the link is still up? The link often stays "up", even if it shows an IP address of 0.0.0.0



  • Tried changing the trigger level to Member Down, but it wouldn't work unless I logged in, went to the WWAN interface, selected it as "Default Gateway", then pressed save. Why can't it figure out what to do if the default gateway goes down?



  • please help



  • Solution (I think):
    Services -> DNS Resolver -> Outgoing Network Interfaces -> select WAN and WWAN (my two wan interfaces - NBN and 4G)

    Previously, all of the interfaces were selected which may have been causing mayhem. It seemed to failover okay once since I changed this. I'll update again with more testing.



  • I think the monitor Ip for gateway n DNS should be different. If you give monitor Ip as a DNS of other wan it might cause an issue.



  • So "monitor IP" can't be the IP of the DNS server for that connection?



  • Just try doing it. It should work.



  • do what? what I'm already doing? or change it? change it to what, exactly? Can you be precise?



  • Try this setting

    ISP. Monitor IP. DNS
    Wan1 8.8.8.8. 1.1.1.1
    Wan2. 8.8.4.4. 9.9.9.9

    The monitor Ip of 1 ISP shouldn't be DNS of other wan.
    What you have done is made 8.8.8.8 as monitor Ip of wan1 n DNS of wan2. So when wan1 is down, a DNS query to 8.8.8.8 go to wan1 interface which is down.
    I guess I have made it clear.



  • Thanks Ashima.

    The DNS and the monitor IP of WAN is 8.8.8.8
    The DNS and the monitor IP of WWAN is 8.8.4.4

    So there's no overlap there. But I'll do some further testing and if it's still not working properly, I'll change the DNS IP to the actual DNS IPs of our ISP. Thanks for picking up on that!



  • oh nice


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy