Arpwatch not starting at boot and miniupnpd not starting at all



  • I have a strange issue that suddenly occurred and suspect they may be related.

    Not sure if its since I added a custom script at startup using shellcmd but suddenly my box doesn't boot to the console, it gets stuck after Configuring firewall. I tried removing my startup script but it still happens.

    Arpwatch also fails to start at boot, I have to manually start it and periodically it fails until I force it to update the mac address database first.

    miniupnpd refuses to start period, nothing in the logs about it at all.

    The rest of the system works fine, other than some issues with unbound not resolving IPv4 randomly, which hasn't happened in a while so possibly related to Cloudflares TLS implementation.

    Is there something I should be looking for in the system that might be hanging the boot scripts?


  • Banned

    This post is deleted!

  • Rebel Alliance Global Moderator

    I would be really suspect of trying to run arpwatch... It has been the suspected reason for lock ups of access to pfsense gui, ssh, console.. There is a redmine created and there is thread.

    I am not sure if new version has been released to address the reported issues.. Give me a sec to dig up the info.

    Here is thread about problems with link to redmine in the thread
    https://forum.netgate.com/topic/131606/arpwatch-broken



  • @johnpoz Duly noted, I don't exactly NEED arpwatch anyway, its miniupnpd that is the big problem as its essential for gaming.


  • Rebel Alliance Global Moderator

    No not really to be honest unless you have multiple consoles and your wanting them to figure out which ports to use each, etc. Normally any well documented game should have the specific ports it needs forwarded documented.



  • @johnpoz I DO have multiple of the same consoles, thus the need. I of course have uPNP only enabled for those devices, its disabled for everything else.

    Interesting, I deleted some of the ACL entries and now it starts. I guess the configuration somehow got corrupted and removing something forced it to be re-created?

    Strangely, simply clicking Save without changing anything didn't fix it as I tried that first.



  • Spoke too soon, had to power down to add a blanking plate (couldn't find enough when I initially built the box) and it still doesn't start up at boot or clicking start on the dashboard.

    It only starts if I go into the configuration and save it. I don't have to make any changes, just click Save.