FTP Stall



  • Hi I have an FTP server PFsense & a nating router.  The way this is setup is currently working is that an ADSL line is connected to the router which has NAT only nothing else and port 21 among other ie P2P to the PFsense box running in VMware with full pfsense with the latest CV.  The server is then connected to PFsense through NAT on the PFsense and the firewall running with port 21 opend on there.  P2P works fine and the HTTP server (all on the same machine) and FTP works when browsing and when you start to download it stalls after about 100k.

    I have tried to retrace my steps and I am not sure what else to do.  I have test the setup with the port on the router directed to the server works fine, it only stalls when pfsense is there.  I have the firewall on consertive.



  • Which version are you running?



  • 1.0 b4 with the latest cvs I did the relang_1



  • The double NAT might be the problem here as you only forwarded port 21 at the router in front of the pfSense. I don't think that you would encounter this behaviour with the pfSense at the real WAN with ftp-helper enabled at WAN. However, you should feed the RC1 update to the webgui though you have run a cvs_sync as the full update contains freebsd upgrades that are not part of the cvs_sync.



  • However, you should feed the RC1 update to the webgui though you have run a cvs_sync as the full update contains freebsd upgrades that are not part of the cvs_sync.

    I am not to sure what you have ment by this wether I need to run a different command or that I shouldn't of run a command at all.  I forgot to say that I do have antivirus pakage installed as well.



  • I just did the cvs_sync.sh so I suppose that has updated more followed by cvs_sync.sh relang1 but it is still stalling.  Shame I don't have a ethernet ADSL modem.  Gone right off these low cost routers.  Pants for P2P

    PFSENSE ALL THE WAY  :D



  • I have fixed this and this was due to some packets now going through the PFsense so the connections got droped.  I solved this by changing the IP address of the internet router to a total different subnet.


Log in to reply