pfsense not receiving a WAN address



  • Morning everyone,

    A little late here but this side project seems a lot more complicated than I had anticipated.

    I use hyper-v to run pfsense in a VM. The installation was quick and easy, no issues there. So if I understand what pfsense does, it is essentially an OS that can replace my netgear router. This seems like something that would be fun to learn. My current problem is that pfsense is not getting an ip address for the wan interface. It has however receive an ip address for the LAN interface.

    My ISP is Charter Communications. I have a modem plugged directly into my WAN port (pfsense). I have my netgear router plugged into my LAN port.

    Here is a screenshot of what windows is showing within ipconfig
    8_1534759562171_Windows ipconfig.PNG
    Within hyper-v this is an image of my settings for my virtual WAN switched.
    7_1534759562171_Virtual Switch WAN.PNG
    Here are my settings for my virtual LAN switch

    6_1534759562171_Virtual Switch LAN.PNG
    Settings of the network adapters within pfsense vm
    0_1534759562169_Network Adapters within Hyper V.PNG

    pfsense WAN general configuration below.
    5_1534759562171_pfsense WAN gen config.PNG 4_1534759562170_pfsense WAN gen config 2.PNG
    Pfsense LAN general config
    3_1534759562170_pfsense LAN gen config.PNG 2_1534759562170_pfsense LAN gen config 2.PNG 1_1534759562170_pfsense interfaces.PNG

    So where should I focus my attention? It's obvious I need to retrace my steps and check something.


  • Rebel Alliance Developer Netgate

    The problem is most likely either in the configuration tying the pfSense WAN to that physical port or with the modem itself. First and easiest thing to test is to power cycle the Cable modem and then reboot the pfSense VM.

    If that still doesn't give you an address, run a packet capture for a while on the pfSense WAN (Diagnostics > Packet Capture) and see if you see any traffic coming back to the interface in response to its DHCP requests.



  • It must be a bad configuration.
    Things I've tried,

    Verify all cables work by testing without pfsense, connecting directly to the modem. No router, no pfsense. Verified all ports on my machine work, all ports on the nic card work, motherboard port also works.

    Called my ISP, they weren't much help and just redirected me to you guys. They say as long as I'm using the modem, they don't care what is plugged into it. No need to register the router or routers.

    I tried spoofing MAC addresses, no luck. WAN is still identified as 0.0.0.0.

    If searching for responses from the DHCP when doing a capture. What should I look for?
    Edit: it did do a DHCP discover. But looks like it never got a response from the modem.



  • Your Netgear was on the same configuration on WAN side (just DHCP)? Nothing like PPPoE configured?

    -Rico


  • Rebel Alliance Global Moderator

    @chris1bass said in pfsense not receiving a WAN address:

    it did do a DHCP discover. But looks like it never got a response from the modem.

    Well there you go explains why pfsense doesn't have a WAN IP, if it asks dhcp server for IP and doesn't get an answer - then no its not going to have an IP ;)

    Work upstream to why offer is not being sent.