Problems running LiveCD



  • Hi everyone.

    I'm trying to install pfsense but am having trouble making the LiveCD work. I have previously installed m0n0wall on the same hardware so it should work.

    I tried 0.90 and the machine hung with a "Can't exec getty" message. So, I downloaded 0.94 but this time it cannot mount the root filesystem. When it comes to mounting /, I get a prompt asking for the filesystem type and path. If I enter it manually, or go with the default there is an error message about not being able to access the image.

    I have tried different cables, a different CD-ROM, and a different CD. I tried disabling DMA and moved to PIO mode 0 in the BIOS. I also tried the "set hw.ata.ata_dma=0" and "set hw.ata.atapi_dma=0" kernel options trick, but to no avail.

    Any ideas?



  • Try changing the CD rom channel, and if its seconadry change it to master, etc.



  • Okay, this is what I tried:

    Downloaded latest pfSense (about an hour ago, 0.95). Tried to boot, but it dropped out to manual input when trying to mount /dev/iso9660/pfSense.

    1. Disabled DMA, set PIO mode 0, no change
    2. Tried safe mode at boot screen, no change
    3. Tried another CD, no change
    4. Tried another cable, no change
    5. Tried another drive, no change
    6. Tested drive with other bootable CDs, OK
    7. Tested drive with various diagnostic tools, OK
    8. Verified downloaded image and CDs, OK

    Any ideas? I can install Windows 2000 without problems on the computer. It's a Cyrix 333, 4GB HDD, 128MB RAM. I ran a full test on the machine at work, using the mega-expensive and very reliable PC-Check software we use, and it said it was fine. I tried other RAM just in case.

    It looks like it can read the CD fine, but then fails to mount the root image. I tried manually specifying the image, but it doesn't work, and there are no error messages so I don't know what's wrong. It just says "Trying to mount cd9660:/dev/iso9660/pfSense" and then drops to manual input. Canceling the manual input causes a kernel panic due to the root FS not being mounted, and the machine reboots.

    I had the same problem with 0.94. The CD works okay on other machines, as does the drive and ribbon cable.



  • Can you try to paste the latest rows before "Trying to mount…". It seems your CD-Rom isn't recognized by FreeBSD. You can also do a photgraph of the monitor.



  • Okay, here is what I copied down from the screen.

    First there is a warning about an unrecognised generic ISA graphics card, and one other unrecognised ISA device. Then, this:

    ad0: 9768MB (Seagate ST310014A 3.09) at ata0-master UDMA66
    Trying to mount root from cd9660:/dev/iso9660/pfSense

    Everything else is scrolled off the screen by that point.

    The machine has an SiS 530 chipset, both CD-ROMs are standard ATAPI models. One is an old 4x drive, the other a newer 52x drive.

    I tried Damn Small Linux and that was fine. I seem to remember that FreeBSD 4 wouldn't install properly from CD though, in the end I took the easy route and installed it via FTP. IPCop works fine too, but doesn't support wireless cards…



  • This is not strictly pfSense related. For unknown reasons, FreeBSD kernel doesn't recognize your cdrom(s). Under the "ad0: " row you should have seen an acd0 and an acd1 one.

    Are you sure Damn Small Linux correctly see them (probably it mounts only a ram filesystem)?

    Can you try booting with ACPI disabled, if you can choice it on the boot menu?



  • Thanks for the response satu.

    I thought maybe it was FreeBSD kernel related too, but I have not been able to find any information. I remember once I had use something like "set hw.ata.atapi.dma=0", but I tried that (and various variations) and it didn't work. I can't find any information relating to FreeBSD and the SiS 530 chipset either.

    The BIOS does not have an option to disable ACPI. I tried the "use ACPI" boot option on the LiveCD but that didn't work.

    Is it possible to use one of the embedded images, or install in some other way?



  • You disable ACPI from the FreeBSD boot menu… The ony with a graphical "FreeBSD" logo.

    Option #1.



  • Ah, yes, option 2 to disable ASPI. I tried it without any luck.

    I also tried changing "PnP OS Installed" in the BIOS to yes. AIUI this prevents the BIOS from trying to assign PCI devices memory and IRQs, and instead allows the OS to do it. Anyway, that didn't work either.

    I'm at a loss now… I can't understand why my CD-ROM wouldn't be detected, as it's clearly working (the kernel is loaded from CD) and the chipset is old, well known and simple.

    I tried these options at the kernel loader prompt too:

    set hw.ata.ata_dma="0"
    set hw.ata.atapi_dma="0"
    boot

    I seem to remember that helped when I installed FreeBSD last time, but it was supposed to be fixed in newer V4 kernels, and of course in V5.

    It's well known that the old SiS chipsets don't always work with DMA enabled, but I now have it turned off. Everything else is standard, plain old ATAPI. The 4x drive doesn't even support DMA, mode 4 is the maximum.



  • is youre hd controler a isa card ????
    i have also a old pc whith isa cards i can boot whith a cheat but afther that freebsd kicks in and i then lost the cddrive and hd drive
    becourse there on the isa card that is disabeld in the freebsd 6.0 kernel



  • No ISA cards, and the IDE controller is on the PCI bus…

    I did eventually get things installed though. I installed a PCI IDE card and connected the HD and the CD-ROM to it. Booted from the CD-ROM, installed, and moved the HD back to the motherboard. Now everything is fine, except my CPU heatsink burns me when I touch it so I might have to add a fan. It's stable though! (Cyrix 333)

    PS. I did have a fan when I was testing earlier, it wasn't down to the CPU overheating!



  • @sullrich:

    Try changing the CD rom channel, and if its seconadry change it to master, etc.

    Sry for bringing back an old topic just wanted to post what worked for me. Hope it helps someone.

    I was having the same issue but noticed the poster never listed he tryed CD-Rom drive as master so I moved CD-Rom drive to master on the secondary ide channel and it cleared up all the issues i was having. Hope this helps anyone else having same issue :)



  • I did try having the drive as master on the 2nd and 1st channels, but anyway…


Log in to reply