SG 1000 stuck in boot loop after initial configuration



  • One of my SG-1000s is stuck in a boot loop. Previously the webconfiguration GUI worked fine, and I was also able to connect via USB. Now all I can figure out how to access is the uboot loader. Frankly, I'm stumped.

    On another known-good device the following step is

    Starting PFLOG...done.
    

    Any help would be greatly appreciated. Thanks!

            __
     _ __  / _|___  ___ _ __  ___  ___
    | '_ \| |_/ __|/ _ \ '_ \/ __|/ _ \
    | |_) |  _\__ \  __/ | | \__ \  __/
    | .__/|_| |___/\___|_| |_|___/\___|
    |_|
    
    
    Welcome to pfSense 2.4.3-RELEASE (Patch 1)...
    
    ...ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib /usr/local/lib/ipsec /usr/local/lib/perl5/5.24/mach/CORE
    Soft Float compatibility ldconfig path:
    done.
    External config loader 1.0 is now starting... mmcsd0s1 mmcsd0s2 mmcsd0s2a
    Launching the init system....... done.
    Initializing.................. done.
    Starting device manager (devd)...done.
    Loading configuration......done.
    Updating configuration...done.
    Checking config backups consistency.................................done.
    Setting up extended sysctls...done.
    Setting timezone...done.
    Configuring loopback interface...done.
    Starting syslog...done.
    Starting Secure Shell Services...done.
    Configuring switch...done.
    Setting up interfaces microcode...done.
    Configuring loopback interface...done.
    Creating wireless clone interfaces...done.
    Configuring LAGG interfaces...done.
    Configuring VLAN interfaces...done.
    Configuring QinQ interfaces...done.
    Configuring WAN interface...done.
    Configuring LAN interface...done.
    Configuring GRE interface...done.
    Configuring CARP settings...done.
    Syncing OpenVPN settings...done.
    Configuring firewall......done.
    Starting PFLOG...done.
    Setting up gateway monitors...done.
    Setting up static routes...done.
    Setting up DNSs...Starting DNS Resolver...done.
    done.
    Synchronizing user settings...done.
    Starting webConfigurator...done.
    Configuring CRON...done.
    Starting NTP time client...done.
    Starting DHCP service...done.
    Starting DHCPv6 service...done.
    Configuring firewall......done.
    mode = 0100666, inum = 60067, fs = /
    panic: ffs_valloc: dup alloc
    Uptime: 1m16s
    Automatic reboot in 15 seconds - press a key on the console to abort
    --> Press a key on the console to reboot,
    --> or switch off the system now.
    
    

  • Galactic Empire Netgate Banned

    That looks like file system corruption. Please try running a file system consistency check. Here's how to do it:

    1. At the console press any key to interrupt the boot loader when you see:
      Hit [Enter] to boot immediately, or any other key for command prompt.
      At the prompt enter: boot -s
      That will boot in single user mode to a question asking for a path to the shell, just press return to reach the # prompt.

    2. At the # prompt run the following command:
      /sbin/fsck -y /

    Run the fsck command at least 6 times; Repeat the command until no errors are reported, even if fsck claims the filesystem has been marked "clean".

    1. Reboot by running: /sbin/rebootThe fastert way to get you back up and running is to re-install.

    That should do it but if it's a larger filesystem issue, fastest way to get you back up and running is to re-install. Here's how to do that https://www.netgate.com/docs/pfsense/solutions/sg-1000/reinstall-pfsense.html



  • I'm guessing you had an ungraceful shutdown.

    I suspect this newer version of BSD or PFsense is leaving file data cached and if it goes down those writes go to etherspace. I've found you have about a 70% chance of file corruption if you pull the plug. From my experience this did NOT use to be the case. It is now!

    I've had 2 different boxes go corrupt from this. The one box a couple years old and this is a new occurrence. Needless to say, I have a UPS running properly now. Mine was an old UPS with no way to command a graceful shutdown. So every once in awhile the batteries would die with now one around to shut it down.



  • This post is deleted!


  • @ivor That worked. I was in the wrong prompt and it was telling me boot -s wasn't a command. Thank you for the help!


  • Galactic Empire Netgate Banned

    You're welcome, glad I could assist!


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy