Shared object "libssh2.so.1" not found, required by "mc"



  • Was able to run midnight commander earlier, but now I started to receive this message.

    How to fix?


  • Netgate Administrator

    What version of pfSense are you running?

    libssh2 is not in the default install on 2.4.3_1 or 2.4.4 as far as I can see though so it was probably installed as a dependency of mc or someother package. If you upgraded since it may have been removed. Or if another package was removed that originally installed it.

    It is in our repo though so you should be able to install it using: pkg install libssh2

    Steve