pfsense 2.4.3 +pf2ad + squidguard + samba 4 (AD)



  • Boa tarde amigo estou a mais de 1 semana na luta pra deixar o proxy funcionando no AD com ACLs de grupo, porém não tive sorte ainda.

    quebrei cabeça aqui até encontrar a dica:

    "Para resolver o problema, tive que rebaixar esse nivel de segurança configurando o ldap server require strong auth como NO."

    matando esse "problema" o usuario aparece no meu log:
    0_1535571665000_f9e7b464-5990-4d7f-9a28-092e949d4165-image.png

    0_1535571734040_86ddc5fd-f206-4488-8f91-00bd095d1dd2-image.png

    porém só a Common ACL é respeitada se bloqueio tudo, ninguém acessa nada e se libero tudo todos usam sem restrição, mesmo com a ACL grupo configurada como podem ver abaixo:
    0_1535571909362_f5f4e390-249e-4d0a-87ab-974dd3804fce-image.png

    o que posso testar aqui pra ver se me retorna algum erro onde possa ter um norte a seguir?



  • @fabiogleao said in pfsense 2.4.3 +pf2ad + squidguard + samba 4 (AD):

    require

    O problema ao qual você se refere é o caso onde os usuários do AD, por vezes, não aparecem no log real time do Squid?
    Se sim, onde você desabilitou essa opção no AD.
    Grato!



  • no meu caso se bloqueio ali no Grou ACL pondo o user 'teste' tudo funciona direitinho, mas se entro com os parâmetros de grupo do AD ele ignora as regras do ACL grupo e se no Common estiver tudo liberado o usuario do grupo acessa normal sem restrição e na real time do squid aparece o usuario e no log do guard tb aparece:

    31.08.2018 15:31:27 10.0.1.74/CPD_02.dominio.lan www.facebook.com:443 Request(ACL_internet_0/blk_BL_socialnet/-) teste CONNECT REDIRECT