PfSense on a laptop - fan at max speed



  • Hello,

    just wanted to find if anyone has ever had or solved this problem. I have installed pfSense on a laptop: Centrino celeron 1.5ghz, 512 mb ram. When it still had XP installed, the fan was very quiet. Well, once i booted it up it started at full speed and then eventually it quieted down after let's say 5-10 seconds.

    Now, with pfSense, the fan on the CPU is running at full speed all the time. I'm thinking, this could be a software problem, maybe FreeBSD doesn't have any drivers to control this?

    Is there anything I can do, besides maybe putting a resistor on the wire that leads to the fan?

    Thank you in advance for your help.



  • Just a little update, someone has mentioned to me that this can be solved if i use "power management", something involving ACPI…

    http://www.freebsd.org/doc/en/books/handbook/acpi-overview.html

    Maybe i should just logon via ssh and find some commands that would enable it?

    Well i hope anyone can point me to the right direction or even type a command or two that would do it. I will try some tomorrow and if i succeed i will post.



  • I would start by updating the laptop to the latest BIOS.  Besides that, I think ACPI is enabled by default with pfSense/FreeBSD.  If you want to tinker, try installing pfSense with ACPI DISABLED by following the instructions here and see if that might help…http://doc.pfsense.org/index.php/HOWTO_disable_acpi


Locked