Gmirror on 1.2.2



  • I have several sites running pfsense.  One of these sites is remote and has been chugging along just fine on 1.2, on top of a gmirror installation.

    I've been upgrading to 1.2.2 over the past week, and failed to do a search to see if gmirror would work on 1.2.2 before upgrading this particular device, and now that it's done, I've found it's not working.  I get this error:```
    gmirror: gmirror and /lib/geom/geom_mirror.so are not synchronized.

    
    Any ideas?  Reinstall is really not an option if it can be avoided at all, as that would require a week of downtime for shipping to and from my colo, plus their outrageous charges for support and shipping :)
    
    Any ideas?  I've had one disk fail in this machine in the past year, which is why I love this gmirror setup.
    
    If I must revert to 1.2, I don't mind, but does anyone have experience doing so, and if so, did they have any luck doing it without physical access to the machine?
    
    Thanks for any and all input, I really appreciate it.




  • @Perry:

    Have just been added to 1.2.3 http://snapshots.pfsense.org/FreeBSD7/RELENG_1_2/

    Wow - I'm completely impressed with the speed of the reply - guess I shouldn't be as pfsense project overall has yet to fail me :)

    Based on that, can I use the "latest.tgz" in the "_updaters" folder at that link to upgrade as I would a regular upgrade from the "System>Firmware>Manual Update" page in the GUI?

    Thanks for your reply!

    EDIT:  I just upgraded and it worked as it should have (the upgrade process).  However - seems that this release is still doing the same thing.  If I run a gmirror status, I get:```

    gmirror status

    gmirror: gmirror and /lib/geom/geom_mirror.so are not synchronized.


  • Rebel Alliance Developer Netgate

    It looks like the new snapshot is not yet on that site. The newest snapshot there is from Feb 11, and the gmirror libraries were just added back on Feb 13th.

    Something may have delayed the build/upload of the snapshot.



  • Ahh ok.  I'm downloading pfSense-Full-Update-1.2.3-20090225-0140.tgz right now and we'll see what happens.



  • Update: I've just updated to:```
    1.2.3-PRERELEASE-TESTING-VERSION
    built on Wed Feb 25 01:40:42 EST 2009

    
    Just to clarify, this was a 1.2 installation that I have simply upgraded to 1.2, 1.2.1, and then gmirror stopped working on 1.2.2.  It now works on this prerelease, but I have not tested with a new installation, merely an upgrade.
    
    Thanks guys!

  • Rebel Alliance Developer Netgate

    It works for me too as of the pfSense-1.2.3-20090224-1127.iso snapshot.

    There was others before that which worked, but had other installer issues. (They tried to put gmirror support back into the installer, in addition to having the libraries on the CD, but it wasn't working properly.)


Log in to reply