pfSense slow internet throughput!



  • Hello everyone

    I'm just just install a fresh new pfsense 2.4.3 on a vmware workstation 14 virtual machine, it has 2 nics ports one for lan and the other for the wan, each nic port is gigabit capable and connect to the virtual machine through a bridge connection, the pfsense runs on a Intel(R) Core(TM) i7-3770S CPU @ 3.10GHz
    4 CPUs: 2 package(s) x 2 core(s)
    AES-NI CPU Crypto: Yes (active)
    and 8gb of ram
    no packages installed, just a clean install of pfsense, my isp is at&t with the gigabit internet service, I setup the at&t gateway with ip passthrough to the pfsense.
    So, having said that, the problem is, the fastest download and upload speed I can get is 200Mbs, not even close to the 940Mbs that the internet connection has.
    I tried several things, that i have found in the forum for tune up the pfsense but still doesn't get any better.
    Any help or clue will be appreciate
    Thanks!



  • Hi,

    Did you test pfSense without using a VM ?
    All NIC's are on auto-select speed ? Hardware offloading is off ?



  • Thanks Gertjan

    No, I don't have a spare computer to test pfsense
    Yes, all NIC's are on auto-select speed and yes hardware offloading is off
    And also I prove it the other way around and still has low speed.



  • I followed the instructions, use VMXNET 3 adapters and have installed the Open-VM-Tools package.

    After that I get around 500-900 Mbps (at times limited by other things) on far less impressive hardware.

    Edit: Oh sorry, I didn't notice you used VMware Workstation instead of ESXI. Why is that, what's the reason for the installation?



  • Check Status -> Interfaces for In/Out Errors, if any replace your cable.



  • I get slow speeds on bare metal (ASRock J3455b and quad intel nic) with pfsense 2.4.3. It works fine on 2.3.5..... Maybe worth a try?

    (update: also works fine on 2.4.4rc)