Trying to upgrade from 2.3.1 issues



  • Hello I am trying to update from 2.3.1 with the shell command of "pkg-static install -f pkg" But I am not sure how to get it to accept the "y" for yes as I am on the PFsense GUI I must be missing something.

    DiagnosticsCommand Prompt
    Shell Output - pkg-static install -f pkg
    pkg-static: Warning: Major OS version upgrade detected. Running "pkg-static install -f pkg" recommended
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 1 package(s) will be affected (of 0 checked):

    Installed packages to be REINSTALLED:
    pkg-1.10.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')

    Number of packages to be reinstalled: 1

    The process will require 1 MiB more space.
    3 MiB to be downloaded.

    Proceed with this action? [y/N]:

    I also tried "pfSense-upgrade -d"

    DiagnosticsCommand Prompt
    Shell Output - pfSense-upgrade -d
    /usr/local/libexec/pfSense-upgrade: gnid: not found

    Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    Locking package pkg... done.

    The following 155 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    python2: 2_3 [pfSense]
    libevent: 2.1.8_1 [pfSense]
    readline: 7.0.3_1 [pfSense]
    libnghttp2: 1.31.1 [pfSense]
    oniguruma6: 6.6.1 [pfSense]
    pecl-rrd1: 1.1.3 [pfSense]
    devcpu-data: 1.16 [pfSense]
    wpa_supplicant: 2.6_2 [pfSense]
    pear-Crypt_CHAP: 1.5.0 [pfSense]
    pear: 1.10.5_1 [pfSense]
    pear-XML_RPC2: 1.1.3 [pfSense]
    pear-HTTP_Request2: 2.3.0,1 [pfSense]
    pear-Net_URL2: 2.2.1 [pfSense]
    pear-Cache_Lite: 1.7.16,1 [pfSense]
    pear-Net_IPv6: 1.3.0.b2_2 [pfSense]
    pear-Net_Growl: 2.7.0 [pfSense]
    pear-Auth_RADIUS: 1.1.0 [pfSense]
    mobile-broadband-provider-info: 20170310 [pfSense]
    hostapd: 2.6_1 [pfSense]
    pear-Mail: 1.4.1,1 [pfSense]
    pear-Net_SMTP: 1.8.0 [pfSense]
    pear-Net_Socket: 1.0.14 [pfSense]
    dnsmasq: 2.78,1 [pfSense]
    libidn2: 2.0.4 [pfSense]
    libunistring: 0.9.8 [pfSense]
    norm: 1.5r6 [pfSense]
    liblz4: 1.8.0,1 [pfSense]
    luajit: 2.1.0.b3 [pfSense]
    py27-ply: 3.10_1 [pfSense]
    py27-setuptools: 36.5.0 [pfSense]
    json-c: 0.13 [pfSense]

    Installed packages to be UPGRADED:
    xinetd: 2.3.15_1 -> 2.3.15_2 [pfSense]
    wol: 0.7.1_2 -> 0.7.1_3 [pfSense]
    unbound: 1.5.8 -> 1.6.8 [pfSense]
    uclcmd: 0.1 -> 0.1_2 [pfSense]
    strongswan: 5.4.0 -> 5.6.2_1 [pfSense]
    ssh_tunnel_shell: 0.1 -> 0.1_1 [pfSense]
    sqlite3: 3.11.1 -> 3.22.0_1 [pfSense]
    smartmontools: 6.4_2 -> 6.6_1 [pfSense]
    rrdtool: 1.5.5_1 -> 1.7.0_1 [pfSense]
    relayd: 5.5.20140810_1 -> 5.5.20140810_2 [pfSense]
    radvd: 1.9.1 -> 2.17_4 [pfSense]
    qstats: 0.1_1 -> 0.2 [pfSense]
    python27: 2.7.11_2 -> 2.7.14_1 [pfSense]
    php56-zlib: 5.6.21 -> 5.6.34 [pfSense]
    php56-xmlwriter: 5.6.21 -> 5.6.34 [pfSense]
    php56-xmlreader: 5.6.21 -> 5.6.34 [pfSense]
    php56-xml: 5.6.21 -> 5.6.34 [pfSense]
    php56-tokenizer: 5.6.21 -> 5.6.34 [pfSense]
    php56-sysvshm: 5.6.21 -> 5.6.34 [pfSense]
    php56-sysvsem: 5.6.21 -> 5.6.34 [pfSense]
    php56-sysvmsg: 5.6.21 -> 5.6.34 [pfSense]
    php56-sqlite3: 5.6.21 -> 5.6.34 [pfSense]
    php56-sockets: 5.6.21 -> 5.6.34 [pfSense]
    php56-simplexml: 5.6.21 -> 5.6.34 [pfSense]
    php56-shmop: 5.6.21 -> 5.6.34 [pfSense]
    php56-session: 5.6.21 -> 5.6.34 [pfSense]
    php56-readline: 5.6.21 -> 5.6.34 [pfSense]
    php56-posix: 5.6.21 -> 5.6.34 [pfSense]
    php56-pfSense-module: 0.12 -> 0.61 [pfSense]
    php56-pdo_sqlite: 5.6.21 -> 5.6.34 [pfSense]
    php56-pdo: 5.6.21 -> 5.6.34 [pfSense]
    php56-pcntl: 5.6.21 -> 5.6.34 [pfSense]
    php56-openssl: 5.6.21 -> 5.6.34 [pfSense]
    php56-opcache: 5.6.21 -> 5.6.34 [pfSense]
    php56-mcrypt: 5.6.21 -> 5.6.34 [pfSense]
    php56-mbstring: 5.6.21 -> 5.6.34 [pfSense]
    php56-ldap: 5.6.21 -> 5.6.34 [pfSense]
    php56-json: 5.6.21 -> 5.6.34 [pfSense]
    php56-hash: 5.6.21 -> 5.6.34 [pfSense]
    php56-gettext: 5.6.21 -> 5.6.34 [pfSense]
    php56-filter: 5.6.21 -> 5.6.34 [pfSense]
    php56-dom: 5.6.21 -> 5.6.34 [pfSense]
    php56-curl: 5.6.21 -> 5.6.34 [pfSense]
    php56-ctype: 5.6.21 -> 5.6.34 [pfSense]
    php56-bz2: 5.6.21 -> 5.6.34 [pfSense]
    php56-bcmath: 5.6.21 -> 5.6.34 [pfSense]
    php56: 5.6.21 -> 5.6.34 [pfSense]
    php-xdebug: 2.2.5 -> 2.5.0 [pfSense]
    php-suhosin: 0.9.38 -> 0.9.38_3 [pfSense]
    pftop: 0.7_6 -> 0.7_8 [pfSense]
    pfSense-rc: 2.3.1 -> 2.4.3_1 [pfSense-core]
    pfSense-pkg-openvpn-client-export: 1.4.3 -> 1.4.17_1 [pfSense]
    pfSense-kernel-pfSense: 2.3.1 -> 2.4.3_1 [pfSense-core]
    pfSense-default-config: 2.3.1 -> 2.4.3_1 [pfSense-core]
    pfSense-base: 2.3.1 -> 2.4.3_1 [pfSense-core]
    pfSense-Status_Monitoring: 1.3_1 -> 1.7.6 [pfSense]
    pfSense: 2.3.1 -> 2.4.3_1 [pfSense]
    perl5: 5.20.3_12 -> 5.24.4 [pfSense]
    pecl-zmq: 1.1.3_1 -> 1.1.3_2 [pfSense]
    pecl-radius: 1.2.7 -> 1.4.0.b1 [pfSense]
    pcre: 8.38_1 -> 8.40_1 [pfSense]
    p7zip: 16.02 -> 16.02_1 [pfSense]
    openvpn-client-export: 2.4.1_1 -> 2.4.6 [pfSense]
    openvpn: 2.3.11 -> 2.4.4_1 [pfSense]
    openldap-client: 2.4.44 -> 2.4.45 [pfSense]
    ntp: 4.2.8p7 -> 4.2.8p11 [pfSense]
    nginx: 1.8.1,2 -> 1.12.2_3,2 [pfSense]
    nettle: 3.2 -> 3.4 [pfSense]
    mpd5: 5.8 -> 5.8_3 [pfSense]
    lzo2: 2.09 -> 2.10_1 [pfSense]
    links: 2.9,1 -> 2.13,1 [pfSense]
    libzmq4: 4.1.4_1 -> 4.2.2_1 [pfSense]
    libxml2: 2.9.3 -> 2.9.7 [pfSense]
    libssh2: 1.6.0_1,2 -> 1.8.0,3 [pfSense]
    libsodium: 1.0.8 -> 1.0.15 [pfSense]
    libiconv: 1.14_9 -> 1.14_11 [pfSense]
    libffi: 3.2.1 -> 3.2.1_2 [pfSense]
    libedit: 3.1.20150325_2 -> 3.1.20170329_2,1 [pfSense]
    ldns: 1.6.17_5 -> 1.7.0_1 [pfSense]
    isc-dhcp43-server: 4.3.3P1_1 -> 4.3.6P1 [pfSense]
    isc-dhcp43-relay: 4.3.3P1_1 -> 4.3.6P1 [pfSense]
    isc-dhcp43-client: 4.3.3P1_1 -> 4.3.6P1 [pfSense]
    ipmitool: 1.8.15_1 -> 1.8.18_1 [pfSense]
    indexinfo: 0.2.4 -> 0.3.1 [pfSense]
    igmpproxy: 0.1_3,1 -> 0.1_5,1 [pfSense]
    idnkit: 1.0_5 -> 1.0_7 [pfSense]
    gmp: 5.1.3_3 -> 6.1.2 [pfSense]
    glib: 2.46.2 -> 2.50.3_1,1 [pfSense]
    gettext-runtime: 0.19.7 -> 0.19.8.1_1 [pfSense]
    filterlog: 0.1_2 -> 0.1_5 [pfSense]
    filterdns: 1.0_9 -> 1.0_16 [pfSense]
    expat: 2.1.0_3 -> 2.2.5 [pfSense]
    dpinger: 2.0 -> 3.0 [pfSense]
    dmidecode: 3.0 -> 3.1_1 [pfSense]
    dhcp6: 20080615_7 -> 20080615.2 [pfSense]
    curl: 7.48.0_1 -> 7.58.0 [pfSense]
    clog: 1.0.1 -> 1.0.1_1 [pfSense]
    check_reload_status: 0.0.7 -> 0.0.8 [pfSense]
    ca_root_nss: 3.22.2 -> 3.36 [pfSense]
    bind-tools: 9.10.3P4 -> 9.11.2P1 [pfSense]

    Installed packages to be REINSTALLED:
    zip-3.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    wrapalixresetbutton-0.0.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    vstr-1.0.15_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    voucher-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    sshlockout_pf-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    scponly-4.8.20110526_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    rate-0.9_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    miniupnpd-1.9.20160113,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    minicron-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    libucl-0.8.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    libmcrypt-2.5.8_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    libltdl-2.4.6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    libdaemon-0.14_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    expiretable-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    dhcpleases6-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    dhcpleases-0.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    cpustats-0.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    cpdup-1.18 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    choparp-20150613 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    bwi-firmware-kmod-3.130.20 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    bsnmp-ucd-0.4.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    bsnmp-regex-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    beep-1.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
    ataidle-2.7.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')

    Number of packages to be installed: 31
    Number of packages to be upgraded: 100
    Number of packages to be reinstalled: 24

    The process will require 66 MiB more space.
    121 MiB to be downloaded.

    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) read: read error: Socket is not connected
    Aborting...

    Unlocking package pkg... done.



  • Hi,

    Before typing a command like :

    pkg-static install -f pkg
    

    Type a command like

    echo Yes
    

    Did it show

    Yes
    

    ?



  • @jonanddad said in Trying to upgrade from 2.3.1 issues:

    pfSense-upgrade -d

    The output only says this now when I added Echo yes

    Shell Output - echo yes pkg-static install -f pkg
    yes pkg-static install -f pkg



  • I also tried echo yes first, executed it and it said "yes" then I ran the command and it said the same as before asking if I wanted to continue.



  • @jonanddad said in Trying to upgrade from 2.3.1 issues:

    Shell Output - echo yes pkg-static install -f pkg
    yes pkg-static install -f pkg

    Not like that.
    I was only checking if your "y" key on your keyboard is working.

    I presume you entered y or Y here :
    @jonanddad said in Trying to upgrade from 2.3.1 issues:

    Proceed with upgrade? (y/N) read: read error: Socket is not connected

    and then you had the

    error: Socket is not connected
    

    message.
    Seems more like some network error, occurring when the upgrade starts.

    edit :
    I just ran pkg-static install -f pkg

    [2.4.3-RELEASE][admin@pfsense.brit-hotel-fumel.net]/root: pkg-static install -f pkg
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be DOWNGRADED:
            pkg: 1.10.5 -> 1.10.3_1 [pfSense]
    
    Number of packages to be downgraded: 1
    
    3 MiB to be downloaded.
    
    Proceed with this action? [y/N]: Y
    [1/1] Fetching pkg-1.10.3_1.txz: 100%    3 MiB 233.2kB/s    00:13
    Checking integrity... done (0 conflicting)
    [1/1] Downgrading pkg from 1.10.5 to 1.10.3_1...
    [1/1] Extracting pkg-1.10.3_1: 100%
    You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.
    

    As you can see, I hit "Y" and the install (downgrade ;) ) continued.
    Btw : I'm using 2.4.3-RELEASE-p1 - surely not the old 2.3.1.

    edit 2: check out the forum, and you will find many issues when upgrading from old versions.
    Keep it mind it will take a couple of seconds to download the latest pfSense version.
    Some more seconds to export your config.
    A minute or so to build a bootable USB stick.
    Some more minutes to install from the USB stick.
    A minute to have LAN working.
    A couple of seconds to import your settings.
    A couple of minutes for pfSense to re install your packages, if you have been using any.
    And your done.